1 0 1 0
0 0 0 0
1 1 1 1
0 1 0 1
The sums of the rows are 2, 0, 4 and 2. The sums of the columns are 2, 2, 2 and 2.
Your job is to write a program that reads in a matrix and checks if it has the parity property. If not, your program should check if the parity property can be established by changing only one bit. If this is not possible either, the matrix should be classified as corrupt.
Input
The input will contain one or more test cases. The first line of each test case contains one integer n (n < 100), representing the size of the matrix. On the next n lines, there will be n integers per line. No other integers than 0 and 1 will occur in the matrix. Input will be terminated by a value of 0 for n.
Output
For each matrix in the input file, print one line. If the matrix already has the parity property, print "OK". If the parity property can be established by changing one bit, print "Change bit (i,j)" where i is the row and j the column of the bit to be changed. Otherwise, print "Corrupt".
Sample Input
4
1 0 1 0
0 0 0 0
1 1 1 1
0 1 0 1
4
1 0 1 0
0 0 1 0
1 1 1 1
0 1 0 1
4
1 0 1 0
0 1 1 0
1 1 1 1
0 1 0 1
0
Sample Output
OK
Change bit (2,3)
Corrupt
Source: University of Ulm Local Contest 1998
**********************************************************************************************************************************
#include<iostream>
using namespace std;
int main()
{
int mat[100][100]={0};
int n;
int count;
int i,j,ii,jj;
bool f1,f2;
while(cin>>n&&n)
{
ii=jj=n+2;
for(i=0;i!=n;i++)
for(j=0;j!=n;j++)
cin>>mat[i][j];
for(i=0;i!=n;i++)//有一行不符合条件即停止匹配,因为题目只要求置换一个数
{
count=0;
for(j=0;j!=n;j++)
count+=mat[i][j];
if(count%2!=0)
{
ii=i+1;//数组下标从0开始
break;
}
}
for(j=0;j!=n;j++)
{
count=0;
for(i=0;i!=n;i++)
count+=mat[i][j];
if(count%2!=0)
{
jj=j+1;
break;
}
}
if(ii==n+2&&jj==n+2)//判断ii和jj是否改动,若否,则表明OK
cout<<"OK"<<endl;
else//如果改动了
{
if(1<=ii&&ii<=n&&1<=jj&&jj<=n)//是否两者都改动了
{
f1=f2=true;
mat[ii-1][jj-1]=1-mat[ii-1][jj-1];
for(i=0;i!=n;i++)
{
count=0;
for(j=0;j!=n;j++)
count+=mat[i][j];
if(count%2!=0)
{
cout<<"Corrupt"<<endl;
f1=false;
break;
}
}
if(f1)
{
for(j=0;j!=n;j++)
{
count=0;
for(i=0;i!=n;i++)
count+=mat[i][j];
if(count%2!=0)
{
cout<<"Corrupt"<<endl;
f2=false;
break;
}
}
if(f2)
cout<<"Change bit ("<<ii<<","<<jj<<")"<<endl;
}
}
else//如果只有一个改变了,则无法变换
cout<<"Corrupt"<<endl;
}
}
return 0;
}