2009杭电 求数列的和

Problem Description
数列的定义如下:
数列的第一项为n,以后各项为前一项的平方根,求数列的前m项的和。

Input
输入数据有多组,每组占一行,由两个整数n(n<10000)和m(m<1000)组成,n和m的含义如前所述。

Output
对于每组输入数据,输出该数列的和,每个测试实例占一行,要求精度保留2位小数。

Sample Input
   
   
   
   
81 4 2 2

Sample Output
   
   
   
   
94.73 3.41

 

#include<stdio.h>
#include<math.h>
//using namespace std;
int main()
{
	int m,n,i;
	while(~scanf("%d%d",&n,&m))
	{
		float s=n;
		float a[1001];
		a[0]=n;
		for(i=1;i<m;++i)
		{
			a[i]=sqrt(a[i-1]);
			s+=a[i];
		}
		printf("%.2f\n",s);
	}
}


 

你可能感兴趣的:(2009杭电 求数列的和)