逃离迷宫 HDU杭电1728 【BFS】

Problem Description
  给定一个m × n (m行, n列)的迷宫,迷宫中有两个位置,gloria想从迷宫的一个位置走到另外一个位置,当然迷宫中有些地方是空地,gloria可以穿越,有些地方是障碍,她必须绕行,从迷宫的一个位置,只能走到与它相邻的4个位置中,当然在行走过程中,gloria不能走到迷宫外面去。令人头痛的是,gloria是个没什么方向感的人,因此,她在行走过程中,不能转太多弯了,否则她会晕倒的。我们假定给定的两个位置都是空地,初始时,gloria所面向的方向未定,她可以选择4个方向的任何一个出发,而不算成一次转弯。gloria能从一个位置走到另外一个位置吗?
 

Input
  第1行为一个整数t (1 ≤ t ≤ 100),表示测试数据的个数,接下来为t组测试数据,每组测试数据中,
  第1行为两个整数m, n (1 ≤ m, n ≤ 100),分别表示迷宫的行数和列数,接下来m行,每行包括n个字符,其中字符'.'表示该位置为空地,字符'*'表示该位置为障碍,输入数据中只有这两种字符,每组测试数据的最后一行为5个整数k, x 1, y 1, x 2, y 2 (1 ≤ k ≤ 10, 1 ≤ x 1, x 2 ≤ n, 1 ≤ y 1, y 2 ≤ m),其中k表示gloria最多能转的弯数,(x 1, y 1), (x 2, y 2)表示两个位置,其中x 1,x 2对应列,y 1, y 2对应行。
 

Output
  每组测试数据对应为一行,若gloria能从一个位置走到另外一个位置,输出“yes”,否则输出“no”。
 

Sample Input
   
   
   
   
2 5 5 ...** *.**. ..... ..... *.... 1 1 1 1 3 5 5 ...** *.**. ..... ..... *.... 2 1 1 1 3
 

Sample Output
   
   
   
   
no yes
 


#include<cstdio>
#include<cstring>
#include<algorithm>
#include<queue>
using namespace std;
struct maze
{
	int x, y;
	int cnt;
};
int row,column;
char map[110][110];
bool vis[110][110];
int sx,sy,ex,ey;
int k;
int dx[]={0,-1,0,1};
int dy[]={1,0,-1,0};

bool judge(int x,int y)
{
	if(x>row||x<1||y>column||y<1) return 0;
	if(map[x][y]=='*') return 0;
	return 1;
}
bool BFS()
{
	memset(vis,0,sizeof(vis));
	int i;
	queue<maze>q;
	maze pos,next;
	pos.x=sx;
	pos.y=sy;
	pos.cnt=-1;
	vis[sx][sy]=1;
	q.push(pos);
	while(!q.empty())
	{
		pos=q.front();
		q.pop();
		if(pos.cnt>=k) continue;
		for(i=0;i<4;++i)
		{
			next.x=pos.x+dx[i];
			next.y=pos.y+dy[i];
			next.cnt=pos.cnt+1;
			while(1)
			{
				if(!judge(next.x,next.y)) break;
				if(next.x==ex&&next.y==ey)
					return 1;
				if(!vis[next.x][next.y])
				{
					q.push(next);
					vis[next.x][next.y]=1;
				}
				next.x+=dx[i];
				next.y+=dy[i];
			}
		}
	}
	return 0;
}
int main()
{
	int T;
	int i,j;
	scanf("%d",&T);
	while(T--)
	{
		scanf("%d%d",&row,&column);
		for(i=1;i<=row;++i)
		{
			scanf("%s",map[i]+1);
		}
		scanf("%d%d%d%d%d",&k,&sy,&sx,&ey,&ex);
		if(sx==ex&&sy==ey)
		{
			printf("yes\n");
			continue;
		}
		if(BFS()) 
			printf("yes\n");
		else printf("no\n");
//		for(i=1;i<=row;++i)
//		{
//			for(j=1;j<=column;++j)
//			{
//				printf("%c",map[i][j]);
//			}
//			puts("");
//		}
	}
	return 0;
}


你可能感兴趣的:(逃离迷宫 HDU杭电1728 【BFS】)