http://acm.hdu.edu.cn/showproblem.php?pid=5477
Problem Description
Master Di plans to take his girlfriend for a travel by bike. Their journey, which can be seen as a line segment of length L, is a road of swamps and flats. In the swamp, it takes A point strengths per meter for Master Di to ride; In the flats, Master Di will regain B point strengths per meter when riding. Master Di wonders:In the beginning, he needs to prepare how much minimum strengths. (Except riding all the time,Master Di has no other choice)
Input
In the first line there is an integer t (
1≤t≤50 ), indicating the number of test cases.
For each test case:
The first line contains four integers, n, A, B, L.
Next n lines, each line contains two integers:
Li,Ri , which represents the interval
[Li,Ri] is swamp.
1≤n≤100,1≤L≤105,1≤A≤10,1≤B≤10,1≤Li<Ri≤L .
Make sure intervals are not overlapped which means
Ri<Li+1 for each i (
1≤i<n ).
Others are all flats except the swamps.
Output
For each text case:
Please output “Case #k: answer”(without quotes) one line, where k means the case number counting from 1, and the answer is his minimum strengths in the beginning.
Sample Input
Sample Output
//通俗易懂,纯暴力
#include <stdio.h>
#include <string.h>
#define min(a,b) (a<b?a:b)
#define INF 0x3fffffff
int dp[100110];
int main()
{
int T, N;
int a, b;
int A, B;
int L;
int cas=0;
scanf("%d",&T);
while(T--)
{
memset(dp,0,sizeof(dp));
int res=0;
scanf("%d%d%d%d",&N,&A,&B,&L);
for(int i=0;i<N;++i)
{
scanf("%d%d",&a,&b);
for(int j=a;j<b;++j)
dp[j]=1;
}
int ans=INF;
for(int i=0;i<L;++i)
{
if(dp[i]) {
res-=A;
ans=min(res,ans);
}
else res+=B;
}
printf("Case #%d: ",++cas);
if(ans>=0) printf("0\n");
else printf("%d\n",-ans);
}
return 0;
}