hdu 4325 Flowers (区间处理 离散化)

http://acm.hdu.edu.cn/showproblem.php?pid=4325

Flowers

Problem Description
As is known to all, the blooming time and duration varies between different kinds of flowers. Now there is a garden planted full of flowers. The gardener wants to know how many flowers will bloom in the garden in a specific time. But there are too many flowers in the garden, so he wants you to help him.
 
Input
The first line contains a single integer t (1 <= t <= 10), the number of test cases.
For each case, the first line contains two integer N and M, where N (1 <= N <= 10^5) is the number of flowers, and M (1 <= M <= 10^5) is the query times.
In the next N lines, each line contains two integer S i and T i (1 <= S i <= T i <= 10^9), means i-th flower will be blooming at time [S i, T i].
In the next M lines, each line contains an integer T i, means the time of i-th query.
 
Output
For each case, output the case number as shown and then print M lines. Each line contains an integer, meaning the number of blooming flowers.
Sample outputs are available for more details.
 
Sample Input
   
   
   
   
2 1 1 5 10 4 2 3 1 4 4 8 1 4 6
 

Sample Output
   
   
   
   
Case #1: 0 Case #2: 1 2 1

题意:有n种花,每种花都有自己的开花时间段从S到E,有m个查询,每个查询都是一个时间点,求这一时刻有几种花在开花;

#include <iostream>
#include <cstring>
#include <cstdio>
#include <algorithm>
#include <cmath>
#include <cstdlib>
#include <limits>
#include <stack>

using namespace std;

#define N 110000
#define met(a, b) memset (a, b, sizeof (a))

typedef long long LL;
//const int INF = ((1<<31)-1);

int ans[N];

int main ()
{
    int t, n, m, nCase = 1;

    scanf ("%d", &t);

    while (t--)
    {
        met (ans, 0);
        scanf ("%d %d", &n, &m);
        int x, y, maxn = 0;

        printf ("Case #%d:\n", nCase++);

        while (n--)
        {
            scanf ("%d %d", &x, &y);
            ans[x]++, ans[y+1]--;
            maxn = max (maxn, y+1);
        }

        for (int i=1; i<=maxn; i++)
            ans[i] += ans[i-1];

        while (m--)
        {
            scanf ("%d", &x);
            printf ("%d\n", ans[x]);
        }
    }
    return 0;
}

你可能感兴趣的:(hdu 4325 Flowers (区间处理 离散化))