hdoj 2055 An easy problem

An easy problem

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 19028    Accepted Submission(s): 12700


Problem Description
we define f(A) = 1, f(a) = -1, f(B) = 2, f(b) = -2, ... f(Z) = 26, f(z) = -26;
Give you a letter x and a number y , you should output the result of y+f(x).
 

Input
On the first line, contains a number T.then T lines follow, each line is a case.each case contains a letter and a number.
 

Output
for each case, you should the result of y+f(x) on a line.
 

Sample Input
   
   
   
   
6 R 1 P 2 G 3 r 1 p 2 g 3
 

Sample Output
   
   
   
   
19 18 10 -17 -14 -4
 

Author
8600
 

Source
校庆杯Warm Up
 

Recommend

linle   |   We have carefully selected several similar problems for you:  2054 2056 2057 2058 2061 

字符输入时要注意

#include<stdio.h>
#include<string.h>
int main()
{
	int i,j,m,t;
	char n;
	scanf("%d",&t);
	while(t--)
	{
		getchar();
		scanf("%c%d",&n,&m);	
		if(n>=65&&n<=90)
		printf("%d\n",m+n-'A'+1);
		else
		printf("%d\n",m-n+'a'-1);
	}
}


你可能感兴趣的:(hdoj 2055 An easy problem)