poj 1013 Counterfeit Dollar

Description

Sally Jones has a dozen Voyageur silver dollars. However, only eleven of the coins are true silver dollars; one coin is counterfeit even though its color and size make it indistinguishable from the real silver dollars. The counterfeit coin has a different weight from the other coins but Sally does not know if it is heavier or lighter than the real coins.
Happily, Sally has a friend who loans her a very accurate balance scale. The friend will permit Sally three weighings to find the counterfeit coin. For instance, if Sally weighs two coins against each other and the scales balance then she knows these two coins are true. Now if Sally weighs
one of the true coins against a third coin and the scales do not balance then Sally knows the third coin is counterfeit and she can tell whether it is light or heavy depending on whether the balance on which it is placed goes up or down, respectively.
By choosing her weighings carefully, Sally is able to ensure that she will find the counterfeit coin with exactly three weighings.
Input

The first line of input is an integer n (n > 0) specifying the number of cases to follow. Each case consists of three lines of input, one for each weighing. Sally has identified each of the coins with the letters A–L. Information on a weighing will be given by two strings of letters and then one of the words up'',down”, or “even”. The first string of letters will represent the coins on the left balance; the second string, the coins on the right balance. (Sally will always place the same number of coins on the right balance as on the left balance.) The word in the third position will tell whether the right side of the balance goes up, down, or remains even.
Output

For each case, the output will identify the counterfeit coin by its letter and tell whether it is heavy or light. The solution will always be uniquely determined.
Sample Input

1
ABCD EFGH even
ABCI EFJK up
ABIJ EFGH even
Sample Output

K is the counterfeit coin and it is light.

如果两边平衡,则两边的都是真的;
如果两边不平衡,给两边都做上标记;
最终哪枚银币被怀疑的次数最多,就是那枚假币。

#include<iostream>
#include<cmath>
#include<cstdio>
using namespace std;
int main()
{
    int n;
    cin>>n;
    while(n--)
    {
        char s1[3][10],s2[3][10],s3[3][10];
        //记录次数
        int s[12]={0};
        //记录真币
        bool flag[12]={0};
        for(int i=0;i<3;i++)
            cin>>s1[i]>>s2[i]>>s3[i];
        for(int i=0;i<3;i++)
        {
            if(s3[i][0]=='u')
            {
                for(int j=0;s1[i][j];j++)
                {
                    s[s1[i][j]-'A']++;
                    s[s2[i][j]-'A']--;
                }
            }
            else if(s3[i][0]=='d')
            {
                for(int j=0;s1[i][j];j++)
                {
                    s[s1[i][j]-'A']--;
                    s[s2[i][j]-'A']++;
                }
            }
            else if(s3[i][0]=='e')
            {
                for(int j=0;s1[i][j];j++)
                {
                    flag[s1[i][j]-'A']=1;
                    flag[s2[i][j]-'A']=1;
                }
            }
        }
        int max=-1;
        int temp;
        //寻找假币
        for(int i=0;i<=11;++i)
        {
            if(flag[i])
                continue;
            if(max<=abs(s[i]))
            {
                max=abs(s[i]);
                temp=i;
            }
        }
        cout<<(char)('A'+temp)<<" is the counterfeit coin and it is ";
        if(s[temp]>0)
            cout<<"heavy."<<endl;
        else
            cout<<"light."<<endl;
    }
    return 0;
}

你可能感兴趣的:(poj)