A + B Problem II
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 278427 Accepted Submission(s): 53689
Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.
Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
Output
For each test case, you should output two lines. The first line is “Case #:”, # means the number of the test case. The second line is the an equation “A + B = Sum”, Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
Sample Input
2
1 2
112233445566778899 998877665544332211
Sample Output
Case 1:
1 + 2 = 3
Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110
解题思路:
1. 测试用例用for循环控制;
2. 数据的读入使用字符串,将字符串按位储存进数组,计算时使用数字按位逐项相加(注意把两个数组倒过来,这样控制位数不出错),在判断最大位是否进1,如果进1,则使最长的数组长度加1,最后再逆序输出相加之和;
3. 使用的头文件string.h用于计算数组长度并比较出最大的一个,作为和数组的长度,再判断是否已溢出;
4. 使用 memset(数组名,0,sizeof(数组名)) 对数组进行清0;memset详细用法见[http://blog.sina.com.cn/s/blog_715d0ae30100yj2d.html ]
5. 数字的ASCLL码值减去‘0’等于数字本身;
代码如下:
#include <stdio.h>
#include <string.h>
int max(int a,int b)
{
return a>b?a:b; //判断长度大小,以最长的数组为加法的最大值
}
int main()
{
char a[1005],b[1005]; //用字符串输入数字,再用数组保存
int a1[1005],a2[1005],a3[1005];
int l1,l2,l;
int i,n,m,k,ok=0;
scanf("%d",&n);
for (k=1;k<=n;k++)
{
memset(a1,0,sizeof(a1));
memset(a2,0,sizeof(a2));
memset(a3,0,sizeof(a3));
scanf("%s%s",a,b);
l1=strlen(a);
l2=strlen(b);
for (i=0;i<l1;i++)
a1[i]=a[l1-1-i]-'0'; //把字符串倒着放进数组,以便于之后相加 ,最后一位数是长度减1
for (i=0;i<l2;i++) //字符数字减‘0 ’得到的是数字本身
a2[i]=b[l2-1-i]-'0';
l=max(l1,l2);
for (i=0;i<l;i++)
{
a3[i]=a1[i]+a2[i]+a3[i];
if (a3[i]>=10)
{
a3[i]=a3[i]%10;
a3[i+1]++;
}
}
if (a3[l]==1)//如果位数进了一个,则使数组长度加1
l++;
if (!ok)
ok++;
else
{
printf("\n");
}
printf("Case %d:\n",k);
printf("%s + %s = ",a,b);
for (i=l-1;i>=0;i--)
printf("%d",a3[i]); //再将得到的数组逆序输出
printf("\n");
}
return 0;
}
c++代码如下:
#include<iostream>
#include<cstring>
using namespace std;
int main()
{
char a[1005],b[1005],c[1005];
int a1[1005],b1[1005],c1[1005];
int l1,l2,l3,i,n,j=0;
cin>>n;
for(j=1;j<=n;j++)
{
memset(a1,0,sizeof(a1));
memset(b1,0,sizeof(b1));
memset(c1,0,sizeof(c1));
cin>>a>>b;
if(strlen(a)>=strlen(b))
{
l1=strlen(a);
l2=strlen(b);
}
else
{
l1=strlen(b);
l2=strlen(a);
}
for(i=0;i<strlen(a);i++)
{
a1[i]=a[strlen(a)-1-i]-'0';
}
for(i=0;i<strlen(b);i++)
{
b1[i]=b[strlen(b)-1-i]-'0';
}
for(i=0;i<l1;i++)
{
c1[i]=a1[i]+b1[i]+c1[i];
if(c1[i]>=10)
{
c1[i]%=10;
c1[i+1]++;
}
}
if(c1[l1]==1)
{
l1++;
}
cout<<"Case "<<j<<":"<<endl;
cout<<a<<" + "<<b<<" = ";
for(i=l1-1;i>=0;i--)
{
cout<<c1[i];
}
if(j==n)
cout<<endl;
else
cout<<endl<<endl;
}
return 0;
}