hdu2460Network【双连通分量求桥 在线求lca】

Submit Status

Description

A network administrator manages a large network. The network consists of N computers and M links between pairs of computers. Any pair of computers are connected directly or indirectly by successive links, so data can be transformed between any two computers. The administrator finds that some links are vital to the network, because failure of any one of them can cause that data can't be transformed between some computers. He call such a link a bridge. He is planning to add some new links one by one to eliminate all bridges.

You are to help the administrator by reporting the number of bridges in the network after each new link is added.
 

Input

The input consists of multiple test cases. Each test case starts with a line containing two integers N(1 ≤ N ≤ 100,000) and M(N - 1 ≤ M ≤ 200,000).
Each of the following M lines contains two integers A and B ( 1≤ A ≠ B ≤ N), which indicates a link between computer A and B. Computers are numbered from 1 to N. It is guaranteed that any two computers are connected in the initial network.
The next line contains a single integer Q ( 1 ≤ Q ≤ 1,000), which is the number of new links the administrator plans to add to the network one by one.
The i-th line of the following Q lines contains two integer A and B (1 ≤ A ≠ B ≤ N), which is the i-th added new link connecting computer A and B.

The last test case is followed by a line containing two zeros.
 

Output

For each test case, print a line containing the test case number( beginning with 1) and Q lines, the i-th of which contains a integer indicating the number of bridges in the network after the first i new links are added. Print a blank line after the output for each test case.
 

Sample Input

     
     
     
     
3 2 1 2 2 3 2 1 2 1 3 4 4 1 2 2 1 2 3 1 4 2 1 2 3 4 0 0
 

Sample Output

     
     
     
     
Case 1: 1 0 Case 2: 2 0
 

这个题好诡异==真心是没有想到与lca有关的==

题意:给定无向图,依次加一些边,求现有的桥的个数

做法:先对原始图求桥,我最开始的思路是不仅要求桥、也要求出每个点所在的BCC序号,加入新边的时候根据缩点的结果找了多少个桥,然而并不需要缩点,缩点的话还要表示bcc之间的关系再建边,好麻烦的。正确做法就只是用lca找新加入两点之间的路径,遇到桥就修改bool变量、桥数减一。只不过本人才疏学浅,没有见过这样的lca写法,之前学过用rmq写的在线lca

spoj Count on a tree【主席树+在线LCA】 

还有离线的并查集lca写法

hdu2586How far away ?【LCA tarjan求最短距离】

这次的lca写法清新简洁,mark一下==

#include <iostream>
#include<cstdio>
#include<cstring>
#include<vector>
#include<algorithm>
using namespace std;
vector<int>G[100009];
int n,m,dfs_clock,bridgenum;
int fa[100009],isbridge[100009],pre[100009];
bool mark[100009];
void init()
{
    for(int i=0;i<=n;i++) G[i].clear();
    bridgenum=dfs_clock=0;
    memset(pre,0,sizeof(pre));
    for(int i=1;i<=n;i++)fa[i]=i;
    memset(isbridge,0,sizeof(isbridge));
}
int dfs(int u,int father)
{
    int lowu=pre[u]=++dfs_clock;
   // printf("u=%d,pre=%d,fa=%d\n",u,pre[u],father);
    for(int i=0;i<G[u].size();i++)
    {
        int v=G[u][i];
        if(!pre[v])
        {
            fa[v]=u;
            int lowv=dfs(v,u);
            lowu=min(lowu,lowv);
            if(lowv>pre[u])
            {
                isbridge[v]=true;
                bridgenum++;
            }
        }
        else if(pre[v]<pre[u]&&v!=father)
            lowu=min(lowu,pre[v]);
    }
    return lowu;
}
void lca(int u,int v)
{
    while(pre[u]>pre[v])
    {
        if(isbridge[u])
        {
            isbridge[u]=0;
            bridgenum--;
        }
        u=fa[u];
       // printf("u=%d,bridge=%d\n",u,bridgenum);
    }
    while(pre[u]<pre[v])
    {
        if(isbridge[v])
        {
            isbridge[v]=0;
            bridgenum--;
        }
        v=fa[v];
       // printf("v=%d,bridge=%d\n",v,bridgenum);
    }
   while(u!=v)
    {
        if(isbridge[u])
        {
            isbridge[u]=0;
            bridgenum--;
        }
        if(isbridge[v])
        {
            isbridge[v]=0;
            bridgenum--;
        }
        u=fa[u];v=fa[v];
    }
}
int main()
{
   // freopen("cin.txt","r",stdin);
   // freopen("out.txt","w",stdout);
    int cas=1,qq;
    while(~scanf("%d%d",&n,&m))
    {
        if(n==0&&m==0)break;
        init();
        while(m--)
        {
            int u,v;
            scanf("%d%d",&u,&v);
            G[u].push_back(v);
            G[v].push_back(u);
        }
        dfs(1,-1);
        printf("Case %d:\n",cas++);
        scanf("%d",&qq);
        while(qq--)
        {
            int u,v;
            scanf("%d%d",&u,&v);
            lca(u,v);
            printf("%d\n",bridgenum);
        }
        puts("");
    }
    return 0;
}



你可能感兴趣的:(HDU,LCA,双连通分量)