HDOJ 5533 Dancing Stars on Me (判断点是否能组成正多边形)

Dancing Stars on Me

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 105    Accepted Submission(s): 74


Problem Description
The sky was brushed clean by the wind and the stars were cold in a black sky. What a wonderful night. You observed that, sometimes the stars can form a regular polygon in the sky if we connect them properly. You want to record these moments by your smart camera. Of course, you cannot stay awake all night for capturing. So you decide to write a program running on the smart camera to check whether the stars can form a regular polygon and capture these moments automatically.

Formally, a regular polygon is a convex polygon whose angles are all equal and all its sides have the same length. The area of a regular polygon must be nonzero. We say the stars can form a regular polygon if they are exactly the vertices of some regular polygon. To simplify the problem, we project the sky to a two-dimensional plane here, and you just need to check whether the stars can form a regular polygon in this plane.
 

Input
The first line contains a integer T indicating the total number of test cases. Each test case begins with an integer n , denoting the number of stars in the sky. Following n lines, each contains 2 integers xi,yi , describe the coordinates of n stars.

1T300
3n100
10000xi,yi10000
All coordinates are distinct.
 

Output
For each test case, please output "`YES`" if the stars can form a regular polygon. Otherwise, output "`NO`" (both without quotes).
 

Sample Input
   
   
   
   
3 3 0 0 1 1 1 0 4 0 0 0 1 1 0 1 1 5 0 0 0 1 0 2 2 2 2 0
 

Sample Output
   
   
   
   
NO YES NO 大意:给出几个点,判断是否能组成一个正多边形 思路:在正多边形各个点之间的边中,正多边形的边长是最短的,枚举每一条边, 查看最短边的数量,如果等于n那么就能组成正多边形,标记一下重边就行了。 ac代码:
#include<stdio.h>
#include<string.h>
#include<math.h>
#include<iostream>
#include<algorithm>
#define MAXN 330 
#define fab(a) (a>0)?(a):(-a)
#define INF 0xfffffff
#define MIN(a,b) (a)>(b)?(b):(a)
#define LL long long
using namespace std;
struct s
{
    int x;
    int y;
}a[MAXN];
LL s[MAXN*4];
int v[MAXN][MAXN];
int main()
{
    int t,i,j,n;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        for(i=0;i<n;i++)
        scanf("%d%d",&a[i].x,&a[i].y);
        int k=0;
        LL M=INF;
        memset(v,0,sizeof(v));
        for(i=0;i<n;i++)
        {
            for(j=i+1;j<n;j++)
            {
                 if(v[i][j]||v[j][i])//检查是否为重边
                 continue;
                 s[k]=(a[i].x-a[j].x)*(a[i].x-a[j].x)+(a[i].y-a[j].y)*(a[i].y-a[j].y);
                 M=MIN(M,s[k]);
                 k++;
                 v[i][j]=1;
            }
        }
        int num=0;
        for(i=0;i<k;i++)
        if(s[i]==M)
        num++;
        if(num==n)
        printf("YES\n");
        else
        printf("NO\n");
    }
    return 0;
}


你可能感兴趣的:(HDOJ 5533 Dancing Stars on Me (判断点是否能组成正多边形))