pat 1077

1077. Kuchiguse (20)

时间限制
100 ms
内存限制
32000 kB
代码长度限制
16000 B
判题程序
Standard
作者
HOU, Qiming

The Japanese language is notorious for its sentence ending particles. Personal preference of such particles can be considered as a reflection of the speaker's personality. Such a preference is called "Kuchiguse" and is often exaggerated artistically in Anime and Manga. For example, the artificial sentence ending particle "nyan~" is often used as a stereotype for characters with a cat-like personality:

  • Itai nyan~ (It hurts, nyan~)
  • Ninjin wa iyada nyan~ (I hate carrots, nyan~)

    Now given a few lines spoken by the same character, can you find her Kuchiguse?

    Input Specification:

    Each input file contains one test case. For each case, the first line is an integer N (2<=N<=100). Following are N file lines of 0~256 (inclusive) characters in length, each representing a character's spoken line. The spoken lines are case sensitive.

    Output Specification:

    For each test case, print in one line the kuchiguse of the character, i.e., the longest common suffix of all N lines. If there is no such suffix, write "nai".

    Sample Input 1:
    3
    Itai nyan~
    Ninjin wa iyadanyan~
    uhhh nyan~
    
    Sample Output 1:
    nyan~
    
    Sample Input 2:
    3
    Itai!
    Ninjinnwaiyada T_T
    T_T
    
    Sample Output 2:
    nai
    
  • 提交代码

     

    感觉自己弱爆了。必须得强化一下了。

     

    #include<iostream>
    #include<string>
    
    using namespace std;
    
    string A[101];
    int main(){
        int n;
        while(scanf("%d",&n)!=EOF){
                getchar();  
                for(int i=0;i<n;i++){
                       getline(cin,A[i]); 
                        }
                
                 int flag=1;   
                 int cnt=0;    
                 for(int i=0;i<256;i++){
                           int len;
                           int len2;
                         for(int j=0;j<n-1;j++){
                                 len=A[j].size()-i-1;
                                 len2=A[j+1].size()-i-1;
                                 if(len<0||len2<0)break;
                                 if(A[j][len]!=A[j+1][len2]){
                                        flag=0;
                                        break;
                                  }
                                  
                                 
                                 
                                 }
                                if(len<0||len2<0)break;
                                if(flag==0)break;
                                else{
                                     cnt++;
                                     }
                         
                         }
                         
                         if(cnt==0){
                            printf("nai\n");}
                         else{
                              int x=A[0].size();
                              
                              for(int i=x-cnt;i<x;i++){
                                      cout<<A[0][i];
                                      }
                              cout<<endl;
          
                              }
             
                }
        
    
        
        return 0;
        }
    


     

    你可能感兴趣的:(pat)