ACM--快速幂--HDOJ 1061--Rightmost Digit


HDOJ地址:http://acm.hdu.edu.cn/showproblem.php?pid=1061

快速幂算法讲解:http://blog.csdn.net/qq_26891045/article/details/51334101


Rightmost Digit

Time Limit:2000/1000 MS (Java/Others)    Memory Limit:65536 /32768 K (Java/Others)
Total Submission(s):45746     Accepted Submission(s): 17221


Problem Description
Given a positive integer N, you should output the most right digit of N^N.
 

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single positive integer N(1<=N<=1,000,000,000).
 

Output
For each test case, you should output the rightmost digit of N^N.
 

Sample Input
   
   
   
   
2 3 4
 

Sample Output
   
   
   
   
7 6
Hint
In the first case, 3 * 3 * 3 = 27, so the rightmost digit is 7. In the second case, 4 * 4 * 4 * 4 = 256, so the rightmost digit is 6.
 



================================天生骄傲的分割线=============================




题目的意思已经非常明确了,就是求n^n的个位数,求它的个位数就相当于进行mod 10运算,这里就直接用快速幂算法,就可以得出结果,题目给定的N可能会比较大,所以用long long比较保险。


#include<iostream>
#include<stdio.h>
using namespace std;
/**
  快速幂算法
*/
long long Calculation(long long a,long long b,long long c){
   int ans=1;
   a=a%c;
   while(b>0){
      if(b%2==1)
        ans=(ans*a)%c;
      b=b/2;
      a=(a*a)%c;
   }
   return ans;
}
int main(){
   int n,N;
   cin>>n;
   while(n--){
     cin>>N;
     printf("%d\n",Calculation(N,N,10));
   }
   return 0;
}




参考博客: http://blog.csdn.net/whjkm/article/details/42803805



你可能感兴趣的:(ACM,快速幂,hdoj,digit,1061,Rightmost)