HDU1010:Tempter of the Bone(DFS)

Problem Description
The doggie found a bone in an ancient maze, which fascinated him a lot. However, when he picked it up, the maze began to shake, and the doggie could feel the ground sinking. He realized that the bone was a trap, and he tried desperately to get out of this maze.

The maze was a rectangle with sizes N by M. There was a door in the maze. At the beginning, the door was closed and it would open at the T-th second for a short period of time (less than 1 second). Therefore the doggie had to arrive at the door on exactly the T-th second. In every second, he could move one block to one of the upper, lower, left and right neighboring blocks. Once he entered a block, the ground of this block would start to sink and disappear in the next second. He could not stay at one block for more than one second, nor could he move into a visited block. Can the poor doggie survive? Please help him.


Input
The input consists of multiple test cases. The first line of each test case contains three integers N, M, and T (1 < N, M < 7; 0 < T < 50), which denote the sizes of the maze and the time at which the door will open, respectively. The next N lines give the maze layout, with each line containing M characters. A character is one of the following:

'X': a block of wall, which the doggie cannot enter;
'S': the start point of the doggie;
'D': the Door; or
'.': an empty block.

The input is terminated with three 0's. This test case is not to be processed.


Output
For each test case, print in one line "YES" if the doggie can survive, or "NO" otherwise.


Sample Input
4 4 5
S.X.
..X.
..XD
....
3 4 5
S.X.
..X.
...D
0 0 0


Sample Output
NO

YES

题意:这个题目的意思是给定你起点S,和终点D,问你是否能在 T 时刻恰好到达终点D。
分析:这样一看很明显是DFS,不过里面涉及到很多剪枝。

奇偶剪枝:

现假设起点为(sx,sy),终点为(ex,ey),给定t步恰好走到终点

s
       
|
       
|
       
|
       
+
e
如图所示(“|”竖走,“—”横走,“+”转弯),易证abs(ex-sx)+abs(ey-sy)为此问题类中任意情况下,起点到终点的最短步数,记做step,此处step1=8;
如果,此最短距离上有一些障碍物不能走,那么移动会偏移最短距离,但是不管偏移几个点,偏移后的距离都是最短距离加上一个偶数距离,这也是可以证明的!

s
 
 
+
 
|
+
     
|
       
+
e
如图,为一般情况下非最短路径的任意走法举例,step2=14;
step2-step1=6,偏移路径为6,偶数(易证);
你发现偏离最短路径导致增加的长度其实只会是偶数!
所以,如果剩余时间减去最短路径,得到一个奇数,那么显然是无法在t时刻准时到达逃生门的!这种情况下,当然不在搜索,直接返回,以节省时间.
#include<iostream>
#include<cmath>
using namespace std;
int f[4][2]= {{0,-1},{0,1},{-1,0},{1,0}};
char map[8][8];
int n,m,t,flag,di,dj;
void dfs(int si,int sj,int cur)
{int x,y;
    if(si>n||sj>m||si<=0||sj<=0)//出界
        return;
    if(cur==t&&si==di&&sj==dj)//到达终点
    {
        flag=1;
    }
    if(flag)
        return;
    int s=abs(di-si)+abs(dj-sj);
    int time=t-cur-s;
    if(time<0||time&1)//看剩下的时间能能否到达终点,time&1则是判断其是否偶数
        return;
    for(int i=0;i<4;i++)
    {
        x=si+f[i][0];
        y=sj+f[i][1];
        if(map[x][y]!='X')
        {
            map[x][y]='X';
            dfs(x,y,cur+1);
            map[x][y]='.';
        }
    }
}
int main()
{int i,j,si,sj;
    while(cin>>n>>m>>t&&n&&m&&t)
    {
        for(i=1;i<=n;i++)
            for(j=1;j<=m;j++)
        {
            cin>>map[i][j];
            if(map[i][j]=='S')
            {
                si=i;
                sj=j;
            }
            else if(map[i][j]=='D')
            {
                di=i;
                dj=j;
            }
        }
        flag=0;
        map[si][sj]='X';
        dfs(si,sj,0);
        if(flag)
            cout<<"YES"<<endl;
        else
            cout<<"NO"<<endl;
    }
}





你可能感兴趣的:(奇偶剪枝,深搜)