Football-概率DP

F - Football
Time Limit:1000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u
Submit  Status  Practice  POJ 3071

Description

Consider a single-elimination football tournament involving 2n teams, denoted 1, 2, …, 2n. In each round of the tournament, all teams still in the tournament are placed in a list in order of increasing index. Then, the first team in the list plays the second team, the third team plays the fourth team, etc. The winners of these matches advance to the next round, and the losers are eliminated. After n rounds, only one team remains undefeated; this team is declared the winner.

Given a matrix P = [pij] such that pij is the probability that team i will beat team j in a match determine which team is most likely to win the tournament.

Input

The input test file will contain multiple test cases. Each test case will begin with a single line containing n (1 ≤ n ≤ 7). The next 2n lines each contain 2nvalues; here, the jth value on the ith line represents pij. The matrix P will satisfy the constraints that pij = 1.0 − pji for all i ≠ j, and pii = 0.0 for all i. The end-of-file is denoted by a single line containing the number −1. Note that each of the matrix entries in this problem is given as a floating-point value. To avoid precision problems, make sure that you use either the double data type instead of float.

Output

The output file should contain a single line for each test case indicating the number of the team most likely to win. To prevent floating-point precision issues, it is guaranteed that the difference in win probability for the top two teams will be at least 0.01.

Sample Input

2
0.0 0.1 0.2 0.3
0.9 0.0 0.4 0.5
0.8 0.6 0.0 0.6
0.7 0.5 0.4 0.0
-1

Sample Output

2

Hint

In the test case above, teams 1 and 2 and teams 3 and 4 play against each other in the first round; the winners of each match then play to determine the winner of the tournament. The probability that team 2 wins the tournament in this case is:

P(2 wins)  P(2 beats 1)P(3 beats 4)P(2 beats 3) + P(2 beats 1)P(4 beats 3)P(2 beats 4)
p21p34p23 + p21p43p24
= 0.9 · 0.6 · 0.4 + 0.9 · 0.4 · 0.5 = 0.396.

The next most likely team to win is team 3, with a 0.372 probability of winning the tournament.

通过题目列出状态转移方程
dp[i][j]代表着第几轮谁胜利的概率
那么dp[0][1.....n]的概率必定为1
接着的难点是如何确定dp[i][j]怎么来
根据题目可以知道,每一轮比赛后,胜利者会与它序列的下一个进行比赛。
如此可以形成一个二叉树
如图: Football-概率DP_第1张图片
所以为了判断两个人是否会比赛,需要压缩得到一个数
如果两个相邻,那么一定会出现一个奇数一个偶数的情况,接着就是计算赢的概率
Football-概率DP_第2张图片
/*
Author: 2486
Memory: 444 KB		Time: 79 MS
Language: C++		Result: Accepted
*/

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
const int maxn=1<<8;
double maps[maxn][maxn];
double dp[10][maxn];
int n;
int main(){
while(~scanf("%d",&n),n!=-1){
    for(int i=0;i<(1<<n);i++){
        for(int j=0;j<(1<<n);j++){
            scanf("%lf",&maps[i][j]);
        }
    }
    memset(dp,0,sizeof(dp));
    for(int i=0;i<(1<<n);i++){
        dp[0][i]=1.0;
    }
    for(int i=1;i<=n;i++){
        for(int j=0;j<(1<<n);j++){
            for(int k=0;k<(1<<n);k++){
                int a=j>>(i-1),b=k>>(i-1);
                if(b&1){
                    b--;
                    if(a==b){
                        dp[i][j]+=dp[i-1][j]*maps[j][k]*dp[i-1][k];
                    }
                }
                else {
                    b++;
                    if(a==b){
                        dp[i][j]+=dp[i-1][j]*maps[j][k]*dp[i-1][k];
                    }
                }
            }
        }
    }
    int index=0;
    double Max=0;
    for(int i=0;i<(1<<n);i++){
        //printf("[%lf]\n",dp[n][i]);
        if(Max<dp[n][i]){
            Max=dp[n][i];
            index=i;
        }
    }
    printf("%d\n",index+1);
}

return 0;
}


你可能感兴趣的:(Football-概率DP)