HDU 3829 Cat VS Dog 二分图匹配

题目描述:

Problem Description
The zoo have N cats and M dogs, today there are P children visiting the zoo, each child has a like-animal and a dislike-animal, if the child’s like-animal is a cat, then his/hers dislike-animal must be a dog, and vice versa.
Now the zoo administrator is removing some animals, if one child’s like-animal is not removed and his/hers dislike-animal is removed, he/she will be happy. So the administrator wants to know which animals he should remove to make maximum number of happy children.

Input
The input file contains multiple test cases, for each case, the first line contains three integers N <= 100, M <= 100 and P <= 500.
Next P lines, each line contains a child’s like-animal and dislike-animal, C for cat and D for dog. (See sample for details)

Output
For each case, output a single integer: the maximum number of happy children.

Sample Input

1 1 2
C1 D1
D1 C1

1 2 4
C1 D1
C1 D1
C1 D2
D2 C1

Sample Output

1
3

Hint
Case 2: Remove D1 and D2, that makes child 1, 2, 3 happy.

题目分析:

n只猫,m只狗,p个人,每个人都有自己喜欢的猫和不喜欢的狗,求将这些猫或狗去除,得到最多的人能满意(有自己喜欢的,没有自己不喜欢的)。
对人进行建边,将有矛盾的人(喜欢他不喜欢,或不喜欢的被别人喜欢)双向建边,用hungary模板求二分图最大匹配,将总人数-匹配值的一半(两次匹配)输出为答案。

代码如下:

#include <iostream>
#include <stdio.h>
#include <string.h>
#include <stdlib.h>
using namespace std;

const int MAXN=510;
char like[MAXN][10],dislike[MAXN][10];
int g[MAXN][MAXN];
int linker[MAXN];
bool used[MAXN];
int n,m,p;

bool dfs(int u)
{
    for(int v=0; v<p; v++)
    {
        if (g[u][v] && !used[v])
        {
            used[v]=true;
            if (linker[v]==-1 || dfs(linker[v]))
            {
                linker[v]=u;
                return true;
            }
        }
    }
    return false;
}

int hungary()
{
    int res=0;
    memset(linker,-1,sizeof(linker));
    for(int u=0; u<p; u++)
    {
        memset(used,false,sizeof(used));
        if (dfs(u)) res++;
    }
    return res;
}

int main()
{
    while(~scanf("%d%d%d",&n,&m,&p))
    {
        memset(g,0,sizeof(g));
        memset(linker,0,sizeof(linker));
        for(int i=0; i<p; i++)
        {
            scanf("%s%s",like[i],dislike[i]);
        }
        for(int i=0; i<p-1; i++)
        {
            for(int j=i+1; j<p; j++)
            {
                if (strcmp(like[i],dislike[j])==0 || strcmp(like[j],dislike[i])==0) 
                {
                    g[i][j]=1;
                    g[j][i]=1;
                }
            }
        }
        int k=hungary();
        printf("%d\n",p-k/2);
    }
    return 0;
}

你可能感兴趣的:(二分图匹配)