CodeForces - 246A Buggy Sorting (模拟)水

CodeForces - 246A (Crawling in process...)
Buggy Sorting
Time Limit:                                                        1MS                          Memory Limit:                                                        262144KB                          64bit IO Format:                            %I64d & %I64u                       

Status

Description

Little boy Valera studies an algorithm of sorting an integer array. After studying the theory, he went on to the practical tasks. As a result, he wrote a program that sorts an array of n integers a1, a2, ..., an in the non-decreasing order. The pseudocode of the program, written by Valera, is given below. The input of the program gets number n and array a.

loop integer variable i from 1 to n - 1
    loop integer variable j from i to n - 1
        if (aj > aj + 1), then swap the values of elements aj and aj + 1

But Valera could have made a mistake, because he hasn't yet fully learned the sorting algorithm. If Valera made a mistake in his program, you need to give a counter-example that makes his program work improperly (that is, the example that makes the program sort the array not in the non-decreasing order). If such example for the given value of n doesn't exist, print -1.

Input

You've got a single integer n(1 ≤ n ≤ 50) — the size of the sorted array.

Output

Print n space-separated integers a1, a2, ..., an(1 ≤ ai ≤ 100) — the counter-example, for which Valera's algorithm won't work correctly. If the counter-example that meets the described conditions is impossible to give, print -1.

If there are several counter-examples, consisting of n numbers, you are allowed to print any of them.

Sample Input

Input
1
Output
-1

Sample Output

Hint

Source

Codeforces Round #151 (Div. 2)
//题意:输入一个n
根据题中的方法将这n个数按从小到大的顺序排序,问是否可行,可以输出-1,否则输出一个序列证明它是错误的。
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;

int main(){
	int n;
	while(~scanf("%d", &n)){
		if(n == 1 || n == 2){
			printf("-1\n");
			continue;
		}
		for(int i = 1; i <= n-1; i++){
			printf("%d ", i + 1);
		}
		puts("1");
	}
	return 0;
}

你可能感兴趣的:(CodeForces - 246A Buggy Sorting (模拟)水)