单链表中重复元素的删除

数据结构实验之链表七:单链表中重复元素的删除

Time Limit: 1000MS Memory limit: 65536K

题目描述

按照数据输入的相反顺序(逆位序)建立一个单链表,并将单链表中重复的元素删除(值相同的元素只保留最后输入的一个)。

输入

第一行输入元素个数n;  
第二行输入n个整数。

输出

第一行输出初始链表元素个数;  
第二行输出按照逆位序所建立的初始链表;
第三行输出删除重复元素后的单链表元素个数;
第四行输出删除重复元素后的单链表。

示例输入

10
21 30 14 55 32 63 11 30 55 30

示例输出

10
30 55 30 11 63 32 55 14 30 21
7
30 55 11 63 32 14 21

提示

 
#include<stdio.h>
#include<stdlib.h>
struct nobe
{
    int data;
    struct nobe * next;
}*head,*p,*t,*q,*tail;
int main()
{
    int n;
    scanf("%d",&n);
    head=(struct nobe *)malloc(sizeof(struct nobe));
    head->next=NULL;
    tail=head;
    int m=n;
    while(n--)
    {
        p=(struct nobe *)malloc(sizeof(struct nobe));
        scanf("%d",&p->data);
        p->next=tail->next;
        tail->next=p;
    }
    printf("%d\n",m);
    p=head->next;
    int kk=1;
    while(p!=NULL)
    {
        if(kk==1)
            kk=0;
        else
        printf(" ");
        printf("%d",p->data);
        p=p->next;
    }
    printf("\n");

    p=head->next;
    t=p;
    int num=0;
    while(p!=NULL)
    {t=p;
     q=p->next;
       while(q!=NULL)
       {
           if(q->data==p->data)
           {
               t->next=q->next;
               num++;
               q=t->next;
           }
           else
           {
               q=q->next;
               t=t->next;
           }
       }p = p->next;
    }
    printf("%d\n",m-num);
    p=head->next;
    int rr=1;
    while(p!=NULL)
    {
        if(rr==1)
            rr=0;
        else
            printf(" ");
        printf("%d",p->data);
        p=p->next;
    }
    printf("\n");
}


你可能感兴趣的:(单链表中重复元素的删除)