Victor and Machine
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 131072/65536 K (Java/Others)
Total Submission(s): 577 Accepted Submission(s): 333
Problem Description
Victor has a machine. When the machine starts up, it will pop out a ball immediately. After that, the machine will pop out a ball every
w seconds. However, the machine has some flaws, every time after
x seconds of process the machine has to turn off for
y seconds for maintenance work. At the second the machine will be shut down, it may pop out a ball. And while it's off, the machine will pop out no ball before the machine restart.
Now, at the
0 second, the machine opens for the first time. Victor wants to know when the
n -th ball will be popped out. Could you tell him?
Input
The input contains several test cases, at most
100 cases.
Each line has four integers
x ,
y ,
w and
n . Their meanings are shown above。
1≤x,y,w,n≤100 .
Output
For each test case, you should output a line contains a number indicates the time when the
n -th ball will be popped out.
Sample Input
2 3 3 3
98 76 54 32
10 9 8 100
Sample Output
Source
BestCoder Round #52 (div.2)
大意:一个机器,每运行x秒就要停止y秒,每运行w秒会吐出一个球,求第n个吐出来时使用了多少时间。
思路:各种少看条件,就把题想麻烦了,注意:
1.每次开启都会吐出一个球,这个刚开始没看到,发现样例都没法算。
2.运行的时间不能累加,就是x<w时,x不能算进运行时间,例如:x=2,w=3,那么运行的时候是不可能吐球的,
只能靠开启机器来吐球。那么这样就很简单了,刚开始我想复杂了,以为可以累加运行时间,哎...
ac代码:
#include<stdio.h>
#include<string.h>
#include<math.h>
#include<iostream>
#include<algorithm>
#define MAXN 2555
#define INF 0xfffffff
#define MIN(a,b) a>b?b:a
using namespace std;
int main()
{
int x,y,w,n;
while(scanf("%d%d%d%d",&x,&y,&w,&n)!=EOF)
{
int num=0;
int sum=0;
int ans=0;
if(x<w)
{
printf("%d\n",(x+y)*(n-1));
continue;
}
int s=x/w;
while(1)
{
num++;
if(num==n)
break;
if(num+s>=n)
ans=ans+w*(n-num),num=n;
else
ans=ans+x+y,num+=s;
if(num==n)
break;
}
printf("%d\n",ans);
}
return 0;
}