POJ 1330 Nearest Common Ancestors LCA_Tarjan

Nearest Common Ancestors
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 23499   Accepted: 12268

Description

A rooted tree is a well-known data structure in computer science and engineering. An example is shown below: 

POJ 1330 Nearest Common Ancestors LCA_Tarjan_第1张图片 
In the figure, each node is labeled with an integer from {1, 2,...,16}. Node 8 is the root of the tree. Node x is an ancestor of node y if node x is in the path between the root and node y. For example, node 4 is an ancestor of node 16. Node 10 is also an ancestor of node 16. As a matter of fact, nodes 8, 4, 10, and 16 are the ancestors of node 16. Remember that a node is an ancestor of itself. Nodes 8, 4, 6, and 7 are the ancestors of node 7. A node x is called a common ancestor of two different nodes y and z if node x is an ancestor of node y and an ancestor of node z. Thus, nodes 8 and 4 are the common ancestors of nodes 16 and 7. A node x is called the nearest common ancestor of nodes y and z if x is a common ancestor of y and z and nearest to y and z among their common ancestors. Hence, the nearest common ancestor of nodes 16 and 7 is node 4. Node 4 is nearer to nodes 16 and 7 than node 8 is. 

For other examples, the nearest common ancestor of nodes 2 and 3 is node 10, the nearest common ancestor of nodes 6 and 13 is node 8, and the nearest common ancestor of nodes 4 and 12 is node 4. In the last example, if y is an ancestor of z, then the nearest common ancestor of y and z is y. 

Write a program that finds the nearest common ancestor of two distinct nodes in a tree. 

Input

The input consists of T test cases. The number of test cases (T) is given in the first line of the input file. Each test case starts with a line containing an integer N , the number of nodes in a tree, 2<=N<=10,000. The nodes are labeled with integers 1, 2,..., N. Each of the next N -1 lines contains a pair of integers that represent an edge --the first integer is the parent node of the second integer. Note that a tree with N nodes has exactly N - 1 edges. The last line of each test case contains two distinct integers whose nearest common ancestor is to be computed.

Output

Print exactly one line for each test case. The line should contain the integer that is the nearest common ancestor.

Sample Input

2
16
1 14
8 5
10 16
5 9
4 6
8 4
4 10
1 13
6 15
10 11
6 7
10 2
16 3
8 1
16 12
16 7
5
2 3
3 4
3 1
1 5
3 5

Sample Output

4
3


题意:给一棵树,给一个询问,找两个点的最近公共祖先。


这是个模版题,然而我发现得太晚了,详情还是看这里吧: 传送门

 

CODE

#include"stdio.h"
#include"iostream"
#include"algorithm"
#include"vector"
using namespace std;
const int maxn = 10000+10;

struct node   ///邻接表
{
    int to;
    int next;
}e[maxn];

int n;
int top;
int ans;
int q1,q2;     ///只有一次询问
int head[maxn];///邻接表头结点
int fa[maxn];  ///并查集父亲节点
int vis[maxn]; ///标记
int in[maxn];  ///入度

void INIT()    ///初始化
{
    top = 0;
    for(int i = 0;i < maxn;i++)
    {
        head[i] = -1;
        vis[i] = 0;
        fa[i] = i;
        in[i] = 0;
    }
}

void add(int u,int v)  ///加边
{
    e[top].to = v;
    e[top].next = head[u];
    head[u] = top++;
}

int Find(int x)
{
    if(x != fa[x])
        fa[x] = Find(fa[x]);
    return fa[x];
}

void Union(int x,int y)   ///连接两个点
{
    int fx = Find(x);
    int fy = Find(y);
    fa[fy] = fx;
}

void Tarjan(int u)
{
    vis[u] = 1;       ///访问的点进行标记
    for(int i = head[u];i != -1;i = e[i].next)
    {
        int t = e[i].to;
        //if(vis[t]) continue;  ///无向图要加这句,本题不用
        Tarjan(t);
        Union(u,t);  ///子节点访问了要连接到父亲结点
    }
    if(u == q1)      ///因为只有一次访问,所以就没用vector存,直接查询
    {
        if(vis[q2])
        {
            ans = Find(q2);
            return;
        }
    }
    else if(u == q2)
    {
        if(vis[q1])
        {
            ans = Find(q1);
            return;
        }
    }
}

int main(void)
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        INIT();
        scanf("%d",&n);
        for(int i = 1;i < n;i++)
        {
            int a,b;
            scanf("%d%d",&a,&b);
            add(a,b);
            in[b]++;
        }
        scanf("%d%d",&q1,&q2);
        for(int i = 1;i <= n;i++)  ///找入度为0的点为根节点
            if(in[i] == 0) Tarjan(i);
        printf("%d\n",ans);
    }
    return 0;
}




swust_fangfangfang

你可能感兴趣的:(poj,Tarjan,LCA)