POJ 2253 Frogger 最短路

Frogger
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 34215   Accepted: 10985

Description

Freddy Frog is sitting on a stone in the middle of a lake. Suddenly he notices Fiona Frog who is sitting on another stone. He plans to visit her, but since the water is dirty and full of tourists' sunscreen, he wants to avoid swimming and instead reach her by jumping. 
Unfortunately Fiona's stone is out of his jump range. Therefore Freddy considers to use other stones as intermediate stops and reach her by a sequence of several small jumps. 
To execute a given sequence of jumps, a frog's jump range obviously must be at least as long as the longest jump occuring in the sequence. 
The frog distance (humans also call it minimax distance) between two stones therefore is defined as the minimum necessary jump range over all possible paths between the two stones. 

You are given the coordinates of Freddy's stone, Fiona's stone and all other stones in the lake. Your job is to compute the frog distance between Freddy's and Fiona's stone. 

Input

The input will contain one or more test cases. The first line of each test case will contain the number of stones n (2<=n<=200). The next n lines each contain two integers xi,yi (0 <= xi,yi <= 1000) representing the coordinates of stone #i. Stone #1 is Freddy's stone, stone #2 is Fiona's stone, the other n-2 stones are unoccupied. There's a blank line following each test case. Input is terminated by a value of zero (0) for n.

Output

For each test case, print a line saying "Scenario #x" and a line saying "Frog Distance = y" where x is replaced by the test case number (they are numbered from 1) and y is replaced by the appropriate real number, printed to three decimals. Put a blank line after each test case, even after the last one.

Sample Input

2
0 0
3 4

3
17 4
19 4
18 5

0

Sample Output

Scenario #1
Frog Distance = 5.000

Scenario #2
Frog Distance = 1.414


点击打开题目链接


给一些点的坐标,求第一个点到第二个点的最短路长度

每条路径的长度为这条路径中相邻两点间最大的距离

注意输出用%.3f

法一:Floyd变形,141MS

#include <cstdio>
#include <cstring>
#include <cmath>
#include <algorithm>
#include <iostream>
using namespace std;

const double INF = 0xfffffff;
const int MAXN = 200 + 10;
double  X[MAXN], Y[MAXN];
double w[MAXN][MAXN];
//两点间距离
double Distance(double x1, double y1, double x2, double y2)
{
    return sqrt((x2 - x1) * (x2 - x1) + (y2 - y1) * (y2 - y1));
}

int main()
{
    //freopen("in.txt", "r", stdin);
    int n, kase = 1;
    while (~scanf("%d", &n), n)
    {
        for (int i = 1; i <= n; i++)        //初始化所有点之间距离为无穷大
            for (int j = 1; j <= n; j++)
                w[i][j] =  INF;

        for (int i = 1; i <= n; i++)
        {
            scanf("%lf%lf", &X[i], &Y[i]);  //保存所有两点间距离
            for (int j = 1; j < i; j++)
                w[i][j] = w[j][i] = Distance(X[i], Y[i], X[j], Y[j]);
        }
        for (int k = 1; k <= n; k++)        //Floyd
        {
            for (int i = 1; i <= n; i++)
            {
                for (int j = 1; j <= n; j++)
                {
                    if (w[i][k] != INF && w[k][j] != INF)
                    {
                        w[i][j] = min(w[i][j], max(w[i][k], w[k][j]));
                    }
                }
            }
        }
        printf("Scenario #%d\nFrog Distance = %.3f\n\n", kase++, w[1][2]);
    }
    return 0;
}

法二:Dijkstra变形,0MS

#include <cstdio>
#include <cstring>
#include <cmath>
#include <algorithm>
#include <iostream>
using namespace std;

const double INF = 0xfffffff;
const int MAXN = 200 + 10;
double  X[MAXN], Y[MAXN];
int vis[MAXN];
double w[MAXN][MAXN], d[MAXN];

double Distance(double x1, double y1, double x2, double y2)
{
    return sqrt((x2 - x1) * (x2 - x1) + (y2 - y1) * (y2 - y1));
}

int main()
{
    //freopen("in.txt", "r", stdin);
    int n, kase = 1;
    while (~scanf("%d", &n), n)
    {
        for (int i = 1; i <= n; i++)        //初始化
            for (int j = 1; j <= n; j++)
                w[i][j] = (i == j ? 0 : INF);

        for (int i = 1; i <= n; i++) d[i] = (i == 1 ? 0 : INF);

        for (int i = 1; i <= n; i++)        //保存距离
        {
            scanf("%lf%lf", &X[i], &Y[i]);
            for (int j = 1; j < i; j++)
                w[i][j] = w[j][i] = Distance(X[i], Y[i], X[j], Y[j]);
        }

        memset(vis, 0, sizeof(vis));    //清除所有点的标号
        for (int i = 1; i < n; i++)     //循环n-1次
        {
            double Min = INF;           //在所有未标号的结点中,选出d最小的结点x
            int x = 1;
            for (int y = 1; y <= n; y++) if (!vis[y] && d[y] < Min) Min = d[x = y];

            vis[x] = 1;                 //给x标记,对于从x出发的所有边(x,y),更新d[y]
            for (int y = 1; y <= n; y++) if (d[y] > max(d[x], w[x][y]))
                    d[y] =  max(d[x], w[x][y]);
        }
        printf("Scenario #%d\nFrog Distance = %.3f\n\n", kase++, d[2]);
    }
    return 0;
}


你可能感兴趣的:(ACM,最短路)