还记得中学时候学过的杨辉三角吗?具体的定义这里不再描述,你可以参考以下的图形:
1
1 1
1 2 1
1 3 3 1
1 4 6 4 1
1 5 10 10 5 1
Input
输入数据包含多个测试实例,每个测试实例的输入只包含一个正整数n(1<=n<=30),表示将要输出的杨辉三角的层数。
Output
对应于每一个输入,请输出相应层数的杨辉三角,每一层的整数之间用一个空格隔开,每一个杨辉三角后面加一个空行。
Sample Input
Sample Output
#include <stdio.h>
#define M 101
int a[M][M]; int main() { int i,j; int n; while(scanf("%d",&n)!=EOF) {
a[1][1] = 1;
a[2][1] = 1;
a[2][2] = 1; for(i=3;i<=n;i++) { for(j=2;j<i;j++) {
a[i][j] = a[i-1][j-1] + a[i-1][j]; }
a[i][1] = 1; //每行 最左边的 赋值为1
a[i][j] = 1; //每行 最右边的 赋值为1 } for(i=1;i<=n;i++) { for(j=1;j<=i;j++) { if(j==1) //输出 每行 最左边的 {
printf("%d",a[i][j]); } else { //输出 剩下 的
printf(" %d",a[i][j]); } }
printf("\n"); }
printf("\n"); } return 0; }