hdu 1058 Humble Numbers (动态规划)

Humble Numbers

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 22063    Accepted Submission(s): 9644


Problem Description
A number whose only prime factors are 2,3,5 or 7 is called a humble number. The sequence 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 12, 14, 15, 16, 18, 20, 21, 24, 25, 27, ... shows the first 20 humble numbers.

Write a program to find and print the nth element in this sequence
 

Input
The input consists of one or more test cases. Each test case consists of one integer n with 1 <= n <= 5842. Input is terminated by a value of zero (0) for n.
 

Output
For each test case, print one line saying "The nth humble number is number.". Depending on the value of n, the correct suffix "st", "nd", "rd", or "th" for the ordinal number nth has to be used like it is shown in the sample output.
 

Sample Input
   
   
   
   
1 2 3 4 11 12 13 21 22 23 100 1000 5842 0
 

Sample Output
   
   
   
   
The 1st humble number is 1. The 2nd humble number is 2. The 3rd humble number is 3. The 4th humble number is 4. The 11th humble number is 12. The 12th humble number is 14. The 13th humble number is 15. The 21st humble number is 28. The 22nd humble number is 30. The 23rd humble number is 32. The 100th humble number is 450. The 1000th humble number is 385875. The 5842nd humble number is 2000000000.
 

Source
University of Ulm Local Contest 1996

 

每个数都可以分解成有限个2 3 5 7 的乘积,dp方程为dp[i] = min(min(dp[p2] * 2, dp[p3] * 3), min(dp[p5] * 5, dp[p7] * 7))

p2, p3, p5, p7分别为2,3,5,7的个数

#include <iostream>
#include <cstring>
#include <cstdlib>
#include <cstdio>
#include <string>
#include <cmath>
#include <set>
#include <queue>
#include <algorithm>
#include <vector>
#include <stack>
const double PI = acos(-1.0);
using namespace std;
#define esp  1e-8
const int inf = 99999999;
//freopen("in.txt","r",stdin); //输入重定向,输入数据将从in.txt文件中读取
//freopen("out.txt","w",stdout); //输出重定向,输出数据将保存在out.txt文件中
int dp[6000];
int main()
{
	int tot = 1;
	int p2, p3, p5, p7;
	p2 = p3 = p5 = p7 = 1;
	dp[1] = 1;
	while (dp[tot] < 2000000000)
	{
		dp[++tot] = min(min(dp[p2] * 2, dp[p3] * 3), min(dp[p5] * 5, dp[p7] * 7));
		if (dp[p2] * 2 == dp[tot])
			p2++;
		if (dp[p3] * 3 == dp[tot])
			p3++;
		if (dp[p5] * 5 == dp[tot])
			p5++;
		if (dp[p7] * 7 == dp[tot])
			p7++;
	}
	int n;
	while (~scanf("%d", &n) && n)
	{
		printf("The %d", n);
		if (n % 10 == 1 && n % 100 != 11)
			printf("st");
		else if (n % 10 == 2 && n % 100 != 12)
			printf("nd");
		else if (n % 10 == 3 && n % 100 != 13)
			printf("rd");
		else
			printf("th");
		printf(" humble number is %d.\n", dp[n]);

	}

}



你可能感兴趣的:(hdu 1058 Humble Numbers (动态规划))