Crazy Bobo
Time Limit: 6000/3000 MS (Java/Others) Memory Limit: 131072/65536 K (Java/Others)
Total Submission(s): 1308 Accepted Submission(s): 400
Problem Description
Bobo has a tree,whose vertices are conveniently labeled by 1,2,...,n.Each node has a weight
wi . All the weights are distrinct.
A set with m nodes
v1,v2,...,vm is a Bobo Set if:
- The subgraph of his tree induced by this set is connected.
- After we sort these nodes in set by their weights in ascending order,we get
u1,u2,...,um ,(that is,
wui<wui+1 for i from 1 to m-1).For any node
x in the path from
ui to
ui+1 (excluding
ui and
ui+1 ),should satisfy
wx<wui .
Your task is to find the maximum size of Bobo Set in a given tree.
Input
The input consists of several tests. For each tests:
The first line contains a integer n (
1≤n≤500000 ). Then following a line contains n integers
w1,w2,...,wn (
1≤wi≤109 ,all the
wi is distrinct).Each of the following n-1 lines contain 2 integers
ai and
bi ,denoting an edge between vertices
ai and
bi (
1≤ai,bi≤n ).
The sum of n is not bigger than 800000.
Output
For each test output one line contains a integer,denoting the maximum size of Bobo Set.
Sample Input
7
3 30 350 100 200 300 400
1 2
2 3
3 4
4 5
5 6
6 7
Sample Output
Author
ZSTU
Source
2015 Multi-University Training Contest 3
#pragma comment(linker, "/STACK:1024000000,1024000000")
#include<cstdio>
#include<cmath>
#include<stdlib.h>
#include<map>
#include<set>
#include<time.h>
#include<vector>
#include<queue>
#include<string>
#include<string.h>
#include<iostream>
#include<algorithm>
using namespace std;
#define eps 1e-8
#define INF 0x3f3f3f3f
#define LL long long
#define max(a,b) ((a)>(b)?(a):(b))
#define min(a,b) ((a)<(b)?(a):(b))
#define maxn 500000 + 10
int w[maxn], a[maxn];
struct edge
{
int v, next;
}e[maxn * 2];
int n;
int vis[maxn];
int head[maxn], tot;
void init()
{
tot = 0;
memset(vis, 0, sizeof(vis));
memset(a, 0, sizeof(a));
memset(head, -1, sizeof(head));
}
void adde(int u, int v)
{
e[tot].v = v;
e[tot].next = head[u];
head[u] = tot++;
}
void dfs(int u)
{
vis[u] = 1;
a[u] = 1;
for(int i=head[u]; i!=-1; i=e[i].next)
{
int v = e[i].v;
//printf("%d--%d\n", u, v);
if(!vis[v])
dfs(v);
a[u] += a[v];
}
}
int main()
{
while(~scanf("%d", &n))
{
init();
for(int i=1; i<=n; i++)
scanf("%d", w + i);
for(int i=1; i<n; i++)
{
int u, v;
scanf("%d%d", &u, &v);
if(w[u] < w[v])
adde(u, v);
else if(w[u] > w[v])
adde(v, u);
}
for(int i=1; i<=n; i++)
if(!vis[i])
dfs(i);
int ans = -1;
for(int i=1; i<=n; i++)
ans = max(ans, a[i]);
printf("%d\n", ans);
}
return 0;
}