POJ 1276 Cash Machine (多重背包转01背包优化)

Cash Machine
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 30096   Accepted: 10848

Description

A Bank plans to install a machine for cash withdrawal. The machine is able to deliver appropriate @ bills for a requested cash amount. The machine uses exactly N distinct bill denominations, say Dk, k=1,N, and for each denomination Dk the machine has a supply of nk bills. For example,

N=3, n1=10, D1=100, n2=4, D2=50, n3=5, D3=10

means the machine has a supply of 10 bills of @100 each, 4 bills of @50 each, and 5 bills of @10 each.

Call cash the requested amount of cash the machine should deliver and write a program that computes the maximum amount of cash less than or equal to cash that can be effectively delivered according to the available bill supply of the machine.

Notes:
@ is the symbol of the currency delivered by the machine. For instance, @ may stand for dollar, euro, pound etc.

Input

The program input is from standard input. Each data set in the input stands for a particular transaction and has the format:

cash N n1 D1 n2 D2 ... nN DN

where 0 <= cash <= 100000 is the amount of cash requested, 0 <=N <= 10 is the number of bill denominations and 0 <= nk <= 1000 is the number of available bills for the Dk denomination, 1 <= Dk <= 1000, k=1,N. White spaces can occur freely between the numbers in the input. The input data are correct.

Output

For each set of data the program prints the result to the standard output on a separate line as shown in the examples below.

Sample Input

735 3  4 125  6 5  3 350
633 4  500 30  6 100  1 5  0 1
735 0
0 3  10 100  10 50  10 10

Sample Output

735
630
0
0

Hint

The first data set designates a transaction where the amount of cash requested is @735. The machine contains 3 bill denominations: 4 bills of @125, 6 bills of @5, and 3 bills of @350. The machine can deliver the exact amount of requested cash.

In the second case the bill supply of the machine does not fit the exact amount of cash requested. The maximum cash that can be delivered is @630. Notice that there can be several possibilities to combine the bills in the machine for matching the delivered cash.

In the third case the machine is empty and no cash is delivered. In the fourth case the amount of cash requested is @0 and, therefore, the machine delivers no cash.




题意:有现今cash,和n种钱币,每种钱币有ni个,价值为Di,求各种钱币组成的不超过cash的最大钱数


思路:该开始写了一个多重背包,但是超时,然后想办法优化,发现把钱币二分拆分了不影响,因为ni个钱币面值都一样,然后就是01背包了。

ac代码:
#include<stdio.h>
#include<string.h>
#include<math.h>
#include<iostream>
#include<algorithm>
#define MAXN 100010
#define max(a,b) a>b?a:b
using namespace std;
int a[MAXN];
int dp[MAXN];
int main()
{
	int M,n,i,j,val,num;
	while(scanf("%d%d",&M,&n)!=EOF)
	{
		int cnt=0;
		for(i=0;i<n;i++)
		{
			scanf("%d%d",&num,&val);
			if(num==0&&val==0)
			continue;
			int k=1;
			while(num-k>0)//既然面值一样,就二分赋值给a
			{
				a[cnt++]=val*k;
				num-=k;
				k*=2;
			}
			a[cnt++]=num*val;
		}
		memset(dp,0,sizeof(dp));
		for(i=0;i<cnt;i++)
		{
			for(j=M;j>=a[i];j--)
			{
				dp[j]=max(dp[j],dp[j-a[i]]+a[i]);
			}
		}
		printf("%d\n",dp[M]);
	}
	return 0;
} 


你可能感兴趣的:(POJ 1276 Cash Machine (多重背包转01背包优化))