UVA 409 统计句子包含单词库中单词的种类数

E - Excuses, Excuses!
Time Limit:3000MS    Memory Limit:0KB    64bit IO Format:%lld & %llu
Submit Status Practice UVA 409
Appoint description:

Description

Judge Ito is having a problem with people subpoenaed for jury duty giving rather lame excuses in order to avoid serving. In order to reduce the amount of time required listening to goofy excuses, Judge Ito has asked that you write a program that will search for a list of keywords in a list of excuses identifying lame excuses. Keywords can be matched in an excuse regardless of case.

Input

Input to your program will consist of multiple sets of data.

  • Line 1 of each set will contain exactly two integers. The first number ( ) defines the number of keywords to be used in the search. The second number ( ) defines the number of excuses in the set to be searched.
  • Lines 2 through K+1 each contain exactly one keyword.
  • Lines K+2 through K+1+E each contain exactly one excuse.
  • All keywords in the keyword list will contain only contiguous lower case alphabetic characters of length L ( ) and will occupy columns 1 through L in the input line.
  • All excuses can contain any upper or lower case alphanumeric character, a space, or any of the following punctuation marks [SPMamp".,!?&] not including the square brackets and will not exceed 70 characters in length.
  • Excuses will contain at least 1 non-space character.

Output

For each input set, you are to print the worst excuse(s) from the list.

  • The worst excuse(s) is/are defined as the excuse(s) which contains the largest number of incidences of keywords.
  • If a keyword occurs more than once in an excuse, each occurrance is considered a separate incidence.
  • A keyword ``occurs" in an excuse if and only if it exists in the string in contiguous form and is delimited by the beginning or end of the line or any non-alphabetic character or a space.

For each set of input, you are to print a single line with the number of the set immediately after the string ``Excuse Set #". (See the Sample Output). The following line(s) is/are to contain the worst excuse(s) one per line exactly as read in. If there is more than one worst excuse, you may print them in any order.

After each set of output, you should print a blank line.

Sample Input

5 3
dog
ate
homework
canary
died
My dog ate my homework.
Can you believe my dog died after eating my canary... AND MY HOMEWORK?
This excuse is so good that it contain 0 keywords.
6 5
superhighway
crazy
thermonuclear
bedroom
war
building
I am having a superhighway built in my bedroom.
I am actually crazy.
1234567890.....,,,,,0987654321?????!!!!!!
There was a thermonuclear war!
I ate my dog, my canary, and my homework ... note outdated keywords?

Sample Output

Excuse Set #1
Can you believe my dog died after eating my canary... AND MY HOMEWORK?

Excuse Set #2
I am having a superhighway built in my bedroom.
There was a thermonuclear war!


题意:找出下列句子中  包含单词库中单词的种类数最多的句子
#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<map>

using namespace std;

map<string,int > Q,QQ;
char c[1000];
char s1[100][1000],s2[100][1000];
char s[1000];
int main()
{
    int n,m,Case=0;
    int len;
    while(~scanf("%d%d",&n,&m))
    {
        Case++;
        Q.clear();
        for(int i=0; i<n; i++)
        {
            scanf("%s",s);
            len=strlen(s);
            for(int j=0; j<len; j++)
                if(s[j]>='A'&&s[j]<='Z')
                    s[j]=s[j]-'A'+'a';
            Q[s]=1;
        }
        getchar();
        for(int i=0; i<m; i++)
        {
            fgets(s1[i],sizeof(c),stdin);
        }
        int Max=0,biao[100],q=0,p=0;
        for(int i=0; i<m; i++)
        {
            len=strlen(s1[i]);
            int num=0;
            QQ.clear();
            for(int j=0; j<len; j++)
            {
                if(s1[i][j]>='A'&&s1[i][j]<='Z')
                    s2[p][q++]=s1[i][j]-'A'+'a';
                else
                    s2[p][q++]=s1[i][j];
                if((s1[i][j]>'z'||s1[i][j]<'a')&&(s1[i][j]>'Z'||s1[i][j]<'A'))
                {
                    s2[p][q-1]='\0';  //将每个单词分离出来,防止包括其他字符如,空格,回车,等
                    //cout<<s2[p];
                    if(Q[s2[p]]==1&&QQ[s2[p]]==0)
                    {
                        num++;
                        //cout<<s2[p]<<"@";
                        QQ[s2[p]]=1;           //防止一个句子中出现多次相同的时候出现累加
                    }
                    p++;
                    q=0;
                }
            }
            biao[i]=num;                   //将每个句子的错词个数保存起来
            if(Max<num)
                Max=num;
        }
        //cout<<Max;
        printf("Excuse Set #%d\n",Case);
        for(int i=0; i<m; i++)
        {
            if(biao[i]==Max)
                printf("%s",s1[i]);
        }
        printf("\n");
    }
}


你可能感兴趣的:(UVA 409 统计句子包含单词库中单词的种类数)