杭电1061

Rightmost Digit

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 26061    Accepted Submission(s): 10018


Problem Description
Given a positive integer N, you should output the most right digit of N^N.
 

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single positive integer N(1<=N<=1,000,000,000).
 

Output
For each test case, you should output the rightmost digit of N^N.
 

Sample Input
   
   
   
   
2 3 4
 

Sample Output
   
   
   
   
7 6
Hint
In the first case, 3 * 3 * 3 = 27, so the rightmost digit is 7. In the second case, 4 * 4 * 4 * 4 = 256, so the rightmost digit is 6.

AC代码如下:

#include <iostream>
using namespace  std;

int process(int n)
{
	int rDigit = n % 10 ; //最右边数字
	int len = 1 ; //循环的长度

	int tmp = rDigit * rDigit % 10 ;
	while (tmp != rDigit)
	{
		len ++ ;
		tmp = tmp * rDigit % 10 ;
	}

	int p = n % len ;
	p = (p + len - 1) % len ;

	tmp = rDigit ;
	for (int i = 0; i < p ; ++ i)
		tmp = tmp * rDigit % 10 ;

	return tmp ;
}

int main(int argc, char** argv)
{
	int caseNum ;
	cin >> caseNum ;
	for (int i = 0; i < caseNum ; ++ i)
	{
		int inValue ;
		cin >> inValue ;
		cout << process(inValue) << endl;
	}
	return 0 ;
}



你可能感兴趣的:(杭电1061)