hdoj 2104 hide handkerchief(辗转相除法)

hide handkerchief

Time Limit: 10000/3000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3764    Accepted Submission(s): 1777


Problem Description
The Children’s Day has passed for some days .Has you remembered something happened at your childhood? I remembered I often played a game called hide handkerchief with my friends.
Now I introduce the game to you. Suppose there are N people played the game ,who sit on the ground forming a circle ,everyone owns a box behind them .Also there is a beautiful handkerchief hid in a box which is one of the boxes .
Then Haha(a friend of mine) is called to find the handkerchief. But he has a strange habit. Each time he will search the next box which is separated by M-1 boxes from the current box. For example, there are three boxes named A,B,C, and now Haha is at place of A. now he decide the M if equal to 2, so he will search A first, then he will search the C box, for C is separated by 2-1 = 1 box B from the current box A . Then he will search the box B ,then he will search the box A.
So after three times he establishes that he can find the beautiful handkerchief. Now I will give you N and M, can you tell me that Haha is able to find the handkerchief or not. If he can, you should tell me "YES", else tell me "POOR Haha".
 

Input
There will be several test cases; each case input contains two integers N and M, which satisfy the relationship: 1<=M<=100000000 and 3<=N<=100000000. When N=-1 and M=-1 means the end of input case, and you should not process the data.
 

Output
For each input case, you should only the result that Haha can find the handkerchief or not.
 

Sample Input
   
   
   
   
3 2 -1 -1
 

Sample Output
   
   
   
   
YES
 

Source
HDU 2007-6 Programming Contest

思路;求n,m互质,最大公约数为一。
因为每个数都要遍历,若有其他公约数,则有遍历不到的,(英语和逻辑思维得好好练了,这还是问的别人)

#include<stdio.h>
int gcd(int x,int y)
{
	int t;
	if(x<y)
	{
		t=x;x=y;y=t;
	}
	if(x%y==0)
		return y;
	else
		return gcd(y,x%y);
}
int main()
{
	int x,y,m;
	while(scanf("%d%d",&x,&y)&&(x!=-1&&y!=-1))
	{
		m=gcd(x,y);
		if(m==1)
		{
			printf("YES\n");
		}
		else
			printf("POOR Haha\n");
	}
	return 0;
 } 


你可能感兴趣的:(hdoj 2104 hide handkerchief(辗转相除法))