FZU 2104 Floor problem(水题)

Problem Description

In this problem, we have f(n,x)=Floor[n/x]. Here Floor[x] is the biggest integer such that no larger than x. For example, Floor[1.1]=Floor[1.9]=1, Floor[2.0]=2.

You are given 3 positive integers n, L and R. Print the result of f(n,L)+f(n,L+1)+…+f(n,R), please.

Input

The first line of the input contains an integer T (T≤100), indicating the number of test cases.

Then T cases, for any case, only 3 integers n, L and R (1≤n, L, R≤10,000, L≤R).

Output

For each test case, print the result of f(n,L)+f(n,L+1)+…+f(n,R) in a single line.
Sample Input

3
1 2 3
100 2 100
100 3 100
Sample Output

0
382
332
Source

“高教社杯”第三届福建省大学生程序设计竞赛

Submit Back Status Discuss

本题是一道水题,估计看懂题目就可以AC了。
下面是AC代码:

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;

int main()
{
    int t,n,l,r;
    scanf("%d",&t);
    while(t--)
    {
        int sum=0;
        scanf("%d%d%d",&n,&l,&r);
        for(int i=l;i<=r;i++)
        {
            sum+=(n/i);
        }
        printf("%d\n",sum);
    }
    return 0;
}

你可能感兴趣的:(FZU)