poj-3273-Monthly Expense

Description

Farmer John is an astounding accounting wizard and has realized he might run out of money to run the farm. He has already calculated and recorded the exact amount of money (1 ≤ moneyi ≤ 10,000) that he will need to spend each day over the next N (1 ≤ N ≤ 100,000) days.

FJ wants to create a budget for a sequential set of exactly M (1 ≤ MN) fiscal periods called "fajomonths". Each of these fajomonths contains a set of 1 or more consecutive days. Every day is contained in exactly one fajomonth.

FJ's goal is to arrange the fajomonths so as to minimize the expenses of the fajomonth with the highest spending and thus determine his monthly spending limit.

Input

Line 1: Two space-separated integers: N and M
Lines 2.. N+1: Line i+1 contains the number of dollars Farmer John spends on the ith day

Output

Line 1: The smallest possible monthly limit Farmer John can afford to live with.

Sample Input

7 5
100
400
300
100
500
101
400

Sample Output

500

Hint

If Farmer John schedules the months so that the first two days are a month, the third and fourth are a month, and the last three are their own months, he spends at most $500 in any month. Any other method of scheduling gives a larger minimum monthly limit.

给N个数,划分为M个块(不得打乱数顺序)。找到一个最好的划分方式,使得块中的最大值 最小。

这道题妥妥的二分啊,挑战程序设计上面已经很多类似的例子,最大值最小化。

#include<cstdio>
#include<iostream>
#include<algorithm>
#include<cstring>
using namespace std;

int n,m;
int a[100005];

int judge(int money)
{
    int g=1;
    int sum=0;
    for(int i=0;i<n;i++)
    {
        if(sum+a[i]<=money)
        {
            sum+=a[i];
        }
        else{
            g++;
            sum=a[i];
        }
        //printf("1\n");
    }
    if(g>m) return 0;
    else return 1;
}

int main()
{
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        int low,high;
        memset(a,0,sizeof(a));
        low=0;
        high=0;
        for(int i=0;i<n;i++)
            {
                scanf("%d",&a[i]);
                high+=a[i];
                if(low<a[i])
                    low=a[i];
            }
        int mid=(low+high)/2;
        while(low<high)
        {
            if(judge(mid))
                high=mid-1;
            else
                low=mid+1;
            mid=(low+high)/2;
        }
        printf("%d\n",mid);
    }
    return 0;
}


你可能感兴趣的:(二分)