HDU 5671 Matrix——BestCoder Round #81(div.1 div.2)

Matrix

Time Limit: 3000/1500 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 0    Accepted Submission(s): 0


Problem Description
There is a matrix  M  that has  n  rows and  m  columns  (1n1000,1m1000) .   Then we perform  q(1q100,000)     operations:

1 x y: Swap row x and row y  (1x,yn) ;

2 x y: Swap column x and column y  (1x,ym) ;

3 x y: Add y to all elements in row x  (1xn,1y10,000) ;

4 x y: Add y to all elements in column x  (1xm,1y10,000) ;
 

Input
There are multiple test cases. The first line of input contains an integer  T(1T20)   indicating the number of test cases. For each test case:

The first line contains three integers  n m  and  q .
The following  n  lines describe the matrix M. (1Mi,j10,000)   for all  (1in,1jm) .
The following  q  lines contains three integers  a(1a4) x  and  y .
 

Output
For each test case, output the matrix  M  after all  q  operations.
 

Sample Input
   
   
   
   
2 3 4 2 1 2 3 4 2 3 4 5 3 4 5 6 1 1 2 3 1 10 2 2 2 1 10 10 1 1 1 2 2 1 2
 

Sample Output
   
   
   
   
12 13 14 15 1 2 3 4 3 4 5 6 1 10 10 1
Hint
Recommand to use scanf and printf
 

Source
BestCoder Round #81 (div.2)
 

/************************************************************************/

附上该题对应的中文题

Matrix

 
 
 Time Limit: 3000/1500 MS (Java/Others)
 
 Memory Limit: 131072/131072 K (Java/Others)
问题描述
有一个nnmm列的矩阵(1 \leq n \leq 1000 ,1 \leq m \leq 1000 )(1n1000,1m1000),在这个矩阵上进行qq  (1 \leq q \leq 100,000)(1q100,000) 个操作:

1 x y: 交换矩阵MM的第xx行和第yy(1 \leq x,y \leq n)(1x,yn);
2 x y: 交换矩阵MM的第xx列和第yy(1 \leq x,y \leq m)(1x,ym);
3 x y: 对矩阵MM的第xx行的每一个数加上y(1 \leq x \leq n,1 \leq y \leq 10,000)y(1xn,1y10,000);
4 x y: 对矩阵MM的第xx列的每一个数加上y(1 \leq x \leq m,1 \leq y \leq 10,000)y(1xm,1y10,000);
输入描述
输入包含多组数据. 第一行有一个整数T (1\leq T\leq 15)T(1T15), 表示测试数据的组数. 对于每组数据:
第一行输入3个整数nn, mm, qq.
接下来的nn行,每行包括mm个整数,表示矩阵MM(1 \leq M_{i,j} \leq 10,000),(1 \leq i \leq n,1 \leq j \leq m)(1Mi,j10,000),(1in,1jm).
最后qq行,每行输入三个整数a(1 \leq a \leq 4)a(1a4), xx, yy
输出描述
对于每组数据,输出经过所有qq个操作以后的矩阵MM
输入样例
2
3 4 2
1 2 3 4
2 3 4 5
3 4 5 6
1 1 2
3 1 10
2 2 2
1 10
10 1
1 1 2
2 1 2
输出样例
12 13 14 15
1 2 3 4
3 4 5 6
1 10
10 1
Hint
建议使用scanf / printf 代替 cin / cout
/****************************************************/

出题人的解题思路:

Matrix

对于交换行、交换列的操作,分别记录当前状态下每一行、每一列是原始数组的哪一行、哪一列即可。

对每一行、每一列加一个数的操作,也可以两个数组分别记录。注意当交换行、列的同时,也要交换增量数组。

输出时通过索引找到原矩阵中的值,再加上行、列的增量。

复杂度O(q+mn)O(q+mn)

在hack的时候,其实我是有点小讶异的,毋庸置疑,这一题肯定是不能暴力求解的,但是还是有人暴力做,而且还过了初测,好吧,挺心机,但我写不出卡TLE的数据
为了做到不超时,显而易见,我们不能把每一次操作通通执行一遍,而是去记录每行每列都发生了什么操作,然后在最后一次计算一遍就可以了,而要做到这一点,我们需要数组pr[]记录后来的每一行分别对应最初的第几行,数组pc[]记录后来的每一列对应最初的第几列,而对x行或x列执行的加法操作,就是对最初的pr[x]行或pc[x]列执行加法操作

/*Sherlock and Watson and Adler*/
#pragma comment(linker, "/STACK:1024000000,1024000000")
#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#include<queue>
#include<stack>
#include<math.h>
#include<vector>
#include<map>
#include<deque>
#include<set>
#include<cmath>
#include<complex>
#include<string>
#include<algorithm>
#include<iostream>
#define exp 1e-10
#define ll long long
using namespace std;
const int N = 1005;
const int M = 10000;
const int inf = 100000000;
const int mod = 2009;
__int64 s[N][N];
struct node
{
    __int64 sum;
}r[N],c[N];
int pr[N],pc[N];
int main()
{
    int t,n,m,q,a,x,y,i,j;
    scanf("%d",&t);
    while(t--)
    {
        memset(r,0,sizeof(r));
        memset(c,0,sizeof(c));
        scanf("%d%d%d",&n,&m,&q);
        for(i=1;i<=n;i++)
        {
            pr[i]=i;
            for(j=1;j<=m;j++)
            {
                pc[j]=j;
                scanf("%I64d",&s[i][j]);
            }
        }
        for(i=0;i<q;i++)
        {
            scanf("%d%d%d",&a,&x,&y);
            if(a==1)
                swap(pr[x],pr[y]);
            else if(a==2)
                swap(pc[x],pc[y]);
            else if(a==3)
                r[pr[x]].sum += y;
            else
                c[pc[x]].sum += y;
        }
        for(i=1;i<=n;i++)
            for(j=1;j<=m;j++)
                printf("%I64d%c",s[pr[i]][pc[j]]+r[pr[i]].sum+c[pc[j]].sum,j!=m?' ':'\n');
    }
    return 0;
}
菜鸟成长记

你可能感兴趣的:(ACM)