hdu 1198 Farm Irrigation(并查集)

Problem Description

Benny has a spacious farm land to irrigate. The farm land is a rectangle, and is divided into a lot of samll squares. Water pipes are placed in these squares. Different square has a different type of pipe. There are 11 types of pipes, which is marked from A to K, as Figure 1 shows.

hdu 1198 Farm Irrigation(并查集)_第1张图片
Figure 1

Benny has a map of his farm, which is an array of marks denoting the distribution of water pipes over the whole farm. For example, if he has a map

ADC
FJK
IHE

then the water pipes are distributed like

hdu 1198 Farm Irrigation(并查集)_第2张图片
Figure 2

Several wellsprings are found in the center of some squares, so water can flow along the pipes from one square to another. If water flow crosses one square, the whole farm land in this square is irrigated and will have a good harvest in autumn.

Now Benny wants to know at least how many wellsprings should be found to have the whole farm land irrigated. Can you help him?

Note: In the above example, at least 3 wellsprings are needed, as those red points in Figure 2 show.

Input

There are several test cases! In each test case, the first line contains 2 integers M and N, then M lines follow. In each of these lines, there are N characters, in the range of 'A' to 'K', denoting the type of water pipe over the corresponding square. A negative M or N denotes the end of input, else you can assume 1 <= M, N <= 50.

Output

For each test case, output in one line the least number of wellsprings needed.

Sample Input

2 2
DK
HF

3 3
ADC
FJK
IHE

-1 -1

Sample Output

2
3
 
 

题意:判断输出连通分支数

#include <cstdio>
#include <cstdlib>
#include <climits>
#include <iostream>
#define MAX 55
using namespace std;
//0,1,2,3分别代表左,上,右,下
//用来存储每一种类型的管道,按照左上右下的顺序,0代表无管道输出,1代表有管道输出
 int type[11][4]={{1,1,0,0},{0,1,1,0},
                        {1,0,0,1},{0,0,1,1},
                        {0,1,0,1},{1,0,1,0},
                        {1,1,1,0},{1,1,0,1},
                        {1,0,1,1},{0,1,1,1},
                        {1,1,1,1}
                        };
int father[MAX*MAX],m,n;
char farm[MAX][MAX];
//初始化函数
void init(int n){
    for(int i=1;i<=n;++i){
        father[i] = i;
    }
}
//查找函数
int find_father(int x){
    if(x!=father[x]){
        father[x] = find_father(father[x]);
    }
    return father[x];
}
//计算连通分支数
int find_ans(int n)
{
    int sum=0;
    for(int i=1;i<=n;i++)
    {
        if(father[i]==i)
        sum++;
    }
    return sum;
}
//引入a管道和b管道的坐标
 void solve(int ax,int ay,int bx,int by,bool dir){  //a管道在b管道前面,故只需要判断b是否越界

if(bx>n || by>m)return; 
bool mark = false; 
int ta,tb; 
ta = farm[ax][ay]-'A';
 tb = farm[bx][by]-'A';  
if(dir){ 
if(type[ta][3] && type[tb][1])mark = true; //竖直方向联通 }
else{ if(type[ta][2] && type[tb][0])mark = true; //水平方向联通 } 
//普通并查集的合并函数 
  if(mark){ 
    int fx = find_father((ax-1)*m+ay);
    int fy = find_father((bx-1)*m+by); 
    if(fx>fy){ father[fy] = fx; } 
    else father[fx]=fy; 
          } 
}

int main(){ 
   int i,j;
   while(scanf("%d %d",&n,&m)!=EOF)
   { 
      if(n==-1 && m==-1)break;
      init(n*m); 
      for(i=1;i<=n;++i)
      { 
         cin>>(farm[i]+1); 
       } 
      for(i=1;i<=n;++i)
      { 
         for(j=1;j<=m;++j)
        { 
           solve(i,j,i+1,j,true); 
           solve(i,j,i,j+1,false); 
         } 
       } 
     int ans=find_ans(n*m);
     printf("%d\n",ans);
   } 
   return 0;
}


你可能感兴趣的:(ACM,杭电,并查集)