hdu1212 Big Number

Problem Description
As we know, Big Number is always troublesome. But it's really important in our ACM. And today, your task is to write a program to calculate A mod B.

To make the problem easier, I promise that B will be smaller than 100000.

Is it too hard? No, I work it out in 10 minutes, and my program contains less than 25 lines.
 

Input
The input contains several test cases. Each test case consists of two positive integers A and B. The length of A will not exceed 1000, and B will be smaller than 100000. Process to the end of file.
 

Output
For each test case, you have to ouput the result of A mod B.
 

Sample Input
   
   
   
   
2 3 12 7 152455856554521 3250
 

Sample Output
   
   
   
   
2 5

1521

解题报告:

在做题之前,先了解这样一些结论:
A*B % C = (A%C * B%C)%C (A+B)%C = (A%C + B%C)%C
如 532 mod 7 =(500%7+30%7+2%7)%7; 当然还有a*b mod c=(a mod c+b mod c)mod c; 如35 mod 3=((5%3)*(7%3))%3
#include <cmath>
#include <ctime>
#include <cctype>
#include <climits>
#include <cstdio>
#include <cstdlib>
#include <cstring>

#include <map>
#include <set>
#include <queue>
#include <stack>
#include <string>
#include <vector>
#include <sstream>
#include <iostream>
#include <algorithm>

#define INF (INT_MAX / 10)
#define clr(arr, val) memset(arr, val, sizeof(arr))
#define pb push_back
#define sz(a) ((int)(a).size())

using namespace std;
typedef set<int> si;
typedef vector<int> vi;
typedef map<int, int> mii;
typedef pair<int, int> pii;
typedef long long ll;

const double esp = 1e-5;

#define N 50100
const int MAX=100010;  
  
  
int main()  
{  
    char str[MAX];  
    int s,len,sum;  
    while(scanf("%s%d",str,&s)!=EOF)  
    {  
        len=strlen(str);  
        sum=0;  
        for(int i=0;i<len;i++)  
        sum=(sum*10+(str[i]-'0')%s)%s;  
        cout<<sum<<endl;  
    }  
    return 0;  
}  



你可能感兴趣的:(数学,HDU)