HDU 1251 统计难题 字典树

统计难题

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 131070/65535 K (Java/Others)
Total Submission(s): 26293    Accepted Submission(s): 10665


Problem Description
Ignatius最近遇到一个难题,老师交给他很多单词(只有小写字母组成,不会有重复的单词出现),现在老师要他统计出以某个字符串为前缀的单词数量(单词本身也是自己的前缀).
 

Input
输入数据的第一部分是一张单词表,每行一个单词,单词的长度不超过10,它们代表的是老师交给Ignatius统计的单词,一个空行代表单词表的结束.第二部分是一连串的提问,每行一个提问,每个提问都是一个字符串.

注意:本题只有一组测试数据,处理到文件结束.
 

Output
对于每个提问,给出以该字符串为前缀的单词的数量.
 

Sample Input
   
   
   
   
banana band bee absolute acm ba b band abc
 

Sample Output
   
   
   
   
2 3 1 0

一道字典树的基础题目,题目要求求以一个单词为前缀的所有单词的数量,首先对所有给出的单词建树,然后再查询,详细细节可以看代码,也可以使用模板。


#include <iostream>
#include <string.h>
#include <stdio.h>
#define MAX 26
using namespace std;


struct trie
{
    int cnt;
    trie* next[MAX];
};
trie* root=new trie;
void insert_node(char *str)
{
    trie* p=root;
    trie* newnode;
    for(int i=0;str[i]!='\0';i++)
    {
        if(p->next[str[i]-'a']==NULL)
        {
            newnode=new trie;
            newnode->cnt=1;
            for(int j=0;j<MAX;j++)
                newnode->next[j]=NULL;
            p->next[str[i]-'a']=newnode;
            p=newnode;
        }
        else
        {
            p=p->next[str[i]-'a'];
            p->cnt++;
        }
    }
}

int find_str(char* str)
{
    trie* p=root;
    for(int i=0;str[i]!='\0';i++)
    {
        if(p->next[str[i]-'a']!=NULL)
            p=p->next[str[i]-'a'];
        else
            return 0;
    }
    return p->cnt;

}


int main()
{
    char ch[MAX];
    for(int i=0;i<MAX;i++)
        root->next[i]=NULL;
    while(gets(ch))
    {
        if(ch[0]=='\0')
            break;
        //printf("hehe:%s\n",ch);
        insert_node(ch);
    }
    while(~scanf("%s",ch))
    {
        printf("%d\n",find_str(ch));
    }
    return 0;
}






你可能感兴趣的:(HDU,字典树,1251,统计难题)