poj 1458 滚动数组

Common Subsequence
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 46139   Accepted: 18919

Description

A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = < x1, x2, ..., xm > another sequence Z = < z1, z2, ..., zk > is a subsequence of X if there exists a strictly increasing sequence < i1, i2, ..., ik > of indices of X such that for all j = 1,2,...,k, x ij = zj. For example, Z = < a, b, f, c > is a subsequence of X = < a, b, c, f, b, c > with index sequence < 1, 2, 4, 6 >. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y.

Input

The program input is from the std input. Each data set in the input contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct.

Output

For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line.

Sample Input

abcfbc         abfcab
programming    contest 
abcd           mnp

Sample Output

4
2
0


题意:求最大相同非连续的字符串(连续的就是KMP了)

两种方法:

第一种,就是单纯的dp,没有加任何修饰

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;

int a[500][500];
char str1[500],str2[500];

int main()
{
    while(scanf("%s%s",str1,str2)!=EOF)
    {
        int len1=strlen(str1);
        int len2=strlen(str2);
        for(int i=0;i<=len1;i++)
            for(int j=0;j<=len2;j++)
            a[i][j]=0;

        for(int i=0;i<len1;i++)
            for(int j=0;j<len2;j++)
                if(str1[i]==str2[j])
                    a[i+1][j+1]=a[i][j]+1;
                else
                    a[i+1][j+1]=max(a[i][j+1],a[i+1][j]);

        printf("%d\n",a[len1][len2]);
    }
    return 0;
}


下面使用了滚动数组,减少了空间并且减少了初始化的时间

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;

char a[500],b[500];
int dp[2][500];

int main()
{
    while(scanf("%s%s",a,b)!=EOF)
    {
        int len_a=strlen(a);
        int len_b=strlen(b);
        memset(dp,0,sizeof(dp));
        for(int i=1;i<=len_a;i++)
            for(int j=1;j<=len_b;j++)
                if(a[i-1]==b[j-1])
                    dp[i%2][j]=dp[(i-1)%2][j-1]+1;
                else
                    dp[i%2][j]=max(dp[(i-1)%2][j],dp[i%2][j-1]);

        printf("%d\n",dp[len_a%2][len_b]);
    }
    return 0;
}



你可能感兴趣的:(poj 1458 滚动数组)