UVALive - 3027 - Corporative Network (并查集!!)

UVALive - 3027
Corporative Network
Time Limit: 3000MS   Memory Limit: Unknown   64bit IO Format: %lld & %llu

Submit Status

Description

A very big corporation is developing its corporative network. In the beginning each of the N enterprises of the corporation, numerated from 1 to N, organized its own computing and telecommunication center. Soon, for amelioration of the services, the corporation started to collect some enterprises in clusters, each of them served by a single computing and telecommunication center as follow. The corporation chose one of the existing centers I (serving the cluster A) and one of the enterprises J in some cluster B (not necessarily the center) and link them with telecommunication line. The length of the line between the enterprises I and J is |I � J|(mod 1000). In such a way the two old clusters are joined in a new cluster, served by the center of the old cluster B. Unfortunately after each join the sum of the lengths of the lines linking an enterprise to its serving center could be changed and the end users would like to know what is the new length. Write a program to keep trace of the changes in the organization of the network that is able in each moment to answer the questions of the users.

Input

Your program has to be ready to solve more than one test case. The first line of the input file will contains only the number T of the test cases. Each test will start with the number N of enterprises (5≤N≤20000). Then some number of lines (no more than 200000) will follow with one of the commands:
E I � asking the length of the path from the enterprise I to its serving center in the moment; 
I I J � informing that the serving center I is linked to the enterprise J.
The test case finishes with a line containing the word O. The I commands are less than N.

Output

The output should contain as many lines as the number of E commands in all test cases with a single number each � the asked sum of length of lines connecting the corresponding enterprise with its serving center.

Sample Input

1
4
E 3
I 3 1
E 3
I 1 2
E 3
I 2 4
E 3
O

Sample Output

0
2
3
5

Source

Regionals 2004 >>  Europe - Southeastern



昨天不知道怎么搞的,,网站崩溃了一天。。微笑

并查集!!



AC代码:

#include <cstdio>
#include <cstring>
#include <algorithm>		//用于使用abs 
using namespace std;

const int maxn = 20000 + 10;
int pa[maxn], d[maxn];

int find(int x)
{			//路径压缩,同时维护d[i]:结点i到树根的距离 
	if(pa[x] != x)
	{
		int root = find(pa[x]);
		d[x] += d[pa[x]];
		return pa[x] = root;
	}
	else return x;
}

int main()
{
	int T;
	scanf("%d", &T);
	while(T--)
	{
		int n, u, v;
		char cmd[9];
		scanf("%d", &n);
		for(int i=0; i <= n; i++) { pa[i] = i; d[i] = 0; }		//初始化,每个结点单独是一棵树 
		
		while(scanf("%s", cmd) && cmd[0] != 'O')
		{
			if(cmd[0] == 'E') 
			{
				scanf("%d", &u);
				find(u);				//调用find函数,其实是维护d[i]的值 
				printf("%d\n", d[u]);
			}
			if(cmd[0] == 'I')
			{
				scanf("%d %d", &u, &v); 
				pa[u] = v; d[u] = abs(u - v) % 1000;
			}
		}
	}
	return 0;
} 







你可能感兴趣的:(ACM,并查集,uvalive)