Asteroids(POJ_3041)

Description

Bessie wants to navigate her spaceship through a dangerous asteroid field in the shape of an N x N grid (1 <= N <= 500). The grid contains K asteroids (1 <= K <= 10,000), which are conveniently located at the lattice points of the grid.

Fortunately, Bessie has a powerful weapon that can vaporize all the asteroids in any given row or column of the grid with a single shot.This weapon is quite expensive, so she wishes to use it sparingly.Given the location of all the asteroids in the field, find the minimum number of shots Bessie needs to fire to eliminate all of the asteroids.

Input

  • Line 1: Two integers N and K, separated by a single space.
  • Lines 2..K+1: Each line contains two space-separated integers R and C (1 <= R, C <= N) denoting the row and column coordinates of an asteroid, respectively.

Output

  • Line 1: The integer representing the minimum number of times Bessie must shoot.

Sample Input

3 4
1 1
1 3
2 2
3 2

Sample Output

2

Hint

INPUT DETAILS:
The following diagram represents the data, where “X” is an asteroid and “.” is empty space:
X.X
.X.
.X.

OUTPUT DETAILS:
Bessie may fire across row 1 to destroy the asteroids at (1,1) and (1,3), and then she may fire down column 2 to destroy the asteroids at (2,2) and (3,2).

Source

USACO 2005 November Gold

代码

咱是照着bin神的模板做的这题,附上链接
1.匈牙利算法的dfs实现模板
2.bin神此题的题解(注释比模板的注释多,更易懂)

//咱的代码(= =其实就是抄了模板)
#include <iostream>
#include <cstdio>
#include <cstring>

using namespace std;

const int MAXN=1000;

int ue,ve;//ue为左边的个数,ve为右边的个数
int g[MAXN][MAXN];
int linker[MAXN];
bool vis[MAXN];

bool dfs(int u)
{
    int v;
    for(v=0;v<ve;v++)
    {
        if(g[u][v]&&!vis[v])
        {
            vis[v]=1;
            if(linker[v]==-1||dfs(linker[v]))
            {
                linker[v]=u;
                return 1;
            }
        }
    }
    return 0;
}

int hungary()
{
    int res=0;
    int u;
    memset(linker,-1,sizeof(linker));
    for(u=0;u<ue;u++)
    {
        memset(vis,0,sizeof(vis));
        if(dfs(u))
            res++;
    }
    return res;
}

int main()
{
    int n,k,a,b;
    scanf("%d%d",&n,&k);
    ue=ve=n;
    for(int i=0;i<k;i++)
    {
        scanf("%d%d",&a,&b);
        g[a-1][b-1]=1;
    }
    printf("%d\n",hungary());
    return 0;
}

你可能感兴趣的:(Asteroids(POJ_3041))