UVA 644 Immediate Decodability

  Immediate Decodability 

An encoding of a set of symbols is said to be immediately decodable if no code for one symbol is the prefix of a code for another symbol. We will assume for this problem that all codes are in binary, that no two codes within a set of codes are the same, that each code has at least one bit and no more than ten bits, and that each set has at least two codes and no more than eight.


Examples: Assume an alphabet that has symbols {A, B, C, D}


The following code is immediately decodable:


A:01 B:10 C:0010 D:0000


but this one is not:


A:01 B:10 C:010 D:0000 (Note that A is a prefix of C)

Input 

Write a program that accepts as input a series of groups of records from a data file. Each record in a group contains a collection of zeroes and ones representing a binary code for a different symbol. Each group is followed by a single separator record containing a single 9; the separator records are not part of the group. Each group is independent of other groups; the codes in one group are not related to codes in any other group (that is, each group is to be processed independently).

Output 

For each group, your program should determine whether the codes in that group are immediately decodable, and should print a single output line giving the group number and stating whether the group is, or is not, immediately decodable.


The Sample Input describes the examples above.

Sample Input 

01
10
0010
0000
9
01
10
010
0000
9

Sample Output 

Set 1 is immediately decodable
Set 2 is not immediately decodable


Miguel A. Revilla 
2000-01-17

题目大意:就是判断是否有"前缀"字符串出现,无则是"is immediately decodable",反之"is not immediately decodable"; 思路一:直接暴力枚举:O(N^2)的时间效率;思路二:先进行排序,有前缀出现的一定是短字符串对于长字符串而言,然后再枚举: 酱紫的话:理论上应该是O(N*log(N)+1/2*(N^2+N))的时间效率的嘛.运行起来竟然都是相等时间.晕.... AC  Program(思路一)
#include<iostream>
#include<algorithm>
#include<stdio.h>
#include<string.h>
using namespace std;
char ch[1000][100];
int num;
/*
int cmp(const void* a,const void* b)
{
  return strcmp((char *)a,(char *)b); 
}*/
bool fn()
{
    
     //qsort(ch,num,sizeof(ch[0]),cmp);
     
     for(int i=0;i<num;i++)
        for(int j=0;j<num;j++)
          {
              if(i==j)continue;
             if(strstr(ch[i],ch[j])-ch[i]==0)
                {
                   //cout<<"ch[i] ch[j] "<<ch[i]<<" "<<ch[j]<<endl;
                   return false;                       
                }      
          }
     return true;
          
}
int main()
{
//freopen("f.out.txt","w",stdout);
num=0;
int cas=1;
while(~scanf("%s",ch[num]))
{
   if(ch[num][0]=='9')
       {
                      
          if(fn())
             printf("Set %d is immediately decodable\n",cas++);
          else
             printf("Set %d is not immediately decodable\n",cas++);
          num=0;               
       }
   else
          num++;                        
}
//system("pause");
return 0;}

AC Program(思路二)
#include<iostream>
#include<algorithm>
#include<stdio.h>
#include<string.h>
using namespace std;
char ch[1000][100];
int num;
int cmp(const void* a,const void* b)
{
  return strlen((char *)a)-strlen((char *)b); 
}
bool fn()
{
     qsort(ch,num,sizeof(ch[0]),cmp);
     //for(int i=0;i<num;i++)
       //cout<<" ch[i] "<<ch[i]<<endl;
     for(int i=0;i<num;i++)
        for(int j=i+1;j<num;j++)
          {
             if(strstr(ch[j],ch[i])-ch[j]==0)
                {
                   return false;                       
                }      
          }
     return true;
          
}
int main()
{
num=0;
int cas=1;
while(~scanf("%s",ch[num]))
{
   if(ch[num][0]=='9')
       {
                      
          if(fn())
             printf("Set %d is immediately decodable\n",cas++);
          else
             printf("Set %d is not immediately decodable\n",cas++);
          num=0;               
       }
   else
          num++;                        
}
//system("pause");
return 0;}


你可能感兴趣的:(UVA 644 Immediate Decodability)