BC - Geometric Progression (等比数列的性质 + java大数)


欢迎参加——每周六晚的BestCoder(有米!)

Geometric Progression

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 421    Accepted Submission(s): 118


Problem Description
Determine whether a sequence is a Geometric progression or not.

In mathematics, a **geometric progression**, also known as a **geometric sequence**, is a sequence of numbers where each term after the first is found by multiplying the previous one by a fixed, non-zero number called the common ratio. For example, the sequence 2, 6, 18, 54, ... is a geometric progression with common ratio 3. Similarly 10, 5, 2.5, 1.25, ... is a geometric sequence with common ratio 1/2.

Examples of a geometric sequence are powers  rk  of a fixed number r, such as  2k  and  3k . The general form of a geometric sequence is

a, ar, ar2, ar3, ar4, 

where r ≠ 0 is the common ratio and a is a scale factor, equal to the sequence's start value.
 

Input
First line contains a single integer  T(T20)  which denotes the number of test cases. 

For each test case, there is an positive integer  n(1n100)  which denotes the length of sequence,and next line has  n  nonnegative numbers  Ai  which allow leading zero.The digit's length of  Ai  no larger than  100 .
 

Output
For each case, output "Yes" or "No".
 

Sample Input
       
       
       
       
4 1 0 3 1 1 1 3 1 4 2 5 16 8 4 2 1
 

Sample Output
       
       
       
       
Yes Yes No Yes
 

Source
import java.util.*;
import java.math.*;
import java.io.*;

public class Main{
    static final int MAXN = 100 + 5;
    static Scanner cin = null;
    static PrintStream cout = null;
    static BigInteger [] A = new BigInteger[MAXN];
    public static void main(String [] agrs){
        cin = new Scanner(System.in);
        cout = new PrintStream(System.out);
        int T, n;
        int Have0, All0;
        T = cin.nextInt();
        while(T -- > 0){
            Have0 = All0 = 0;
            n = cin.nextInt();
            for(int i = 0;i < n;i ++){
                A[i] = cin.nextBigInteger();
                if(A[i].equals(BigInteger.ZERO)) {
                    Have0 ++; All0 ++;
                }
            }
            boolean flag = true;
            for(int i = 0;i < n - 2;i ++){
                if(!A[i].multiply(A[i + 2]).equals(A[i + 1].pow(2))){
                    flag = false;
                    break;
                }
            }
            if(n > All0 && Have0 > 0) flag = false;
            if(flag) cout.println("Yes");
            else cout.println("No");
        }
    }
}

 

你可能感兴趣的:(BC - Geometric Progression (等比数列的性质 + java大数))