Max Sum
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 145161 Accepted Submission(s): 33897
Problem Description
Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.
Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).
Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.
Sample Input
2
5 6 -1 5 4 -7
7 0 6 -1 1 -6 7 -5
Sample Output
Case 1:
14 1 4
Case 2:
7 1 6
我们用内存换取时间的方法来做,建立三个数组,num保存数据,dp[i]=max(dp[i-1]+num[i] , num[i] )是状态转移方程,p数组用来记录dp的变化,dp[i-1]+num[i]时为1,否则为0.
#include<stdio.h>
int T,N,num[100001],dp[100001],p[100001],sp,ep,i,j;
void main()
{
scanf("%d",&T);
for(i=0;i<T;i++)
{
scanf("%d",&N);
for(j=0;j<N;j++)
scanf("%d",&num[j]);
dp[0]=num[0];
sp=ep=1;p[0]=0;
for(j=1;j<N;j++)
{
if((dp[j-1]+num[j])>=num[j])
{
dp[j]=(dp[j-1]+num[j]);
p[j]=1;
}
else
{
(dp[j]=num[j]);
p[j]=0;
}
}
for(j=1;j<N;j++)
{ if(dp[j]>dp[0])
{
dp[0]=dp[j];
ep=j+1;
}
}
sp=ep;
for(j=ep;j>=1;j--)
{
if(p[j]==1&&p[j-1]==0)
{
sp=j;
break;
}
}
printf("Case %d:\n%d %d %d\n",i+1,dp[0],sp,ep);
i<(T-1)?printf("\n"):1;
}
}