HDOJ 1241Oil Deposits(BFS)

Problem Description
The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid. 
 

Input
The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*', representing the absence of oil, or `@', representing an oil pocket.
 

Output
For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.
 

Sample Input
   
   
   
   
1 1 * 3 5 *@*@* **@** *@*@* 1 8 @@****@* 5 5 ****@ *@@*@ *@**@ @@@*@ @@**@ 0 0
 

Sample Output
   
   
   
   
0 1 2 2
//
//  main.cpp
//  oil dfs
//
//  Created by 张嘉韬 on 16/3/26.
//  Copyright © 2016年 张嘉韬. All rights reserved.
//

#include <iostream>
#include <cstring>
using namespace std;
int m,n,map[110][110],counter;
int dx[]={-1,-1,-1,0,0,1,1,1};
int dy[]={-1,0,1,-1,1,-1,0,1};
void pirnt()
{
    for(int i=1;i<=m;i++)
    {
        for(int j=1;j<=n;j++)
        {
            cout<<map[i][j]<<" ";
        }
        cout<<endl;
    }
    cout<<endl;
}
int safe(int x,int y)
{
    int flag=1;
    if(x<=0||x>m||y<=0||y>n||map[x][y]==0) flag=0;
    return flag;
}
void dfs(int x,int y)
{
    int tempx,tempy;
    for(int i=0;i<8;i++)
    {
        tempx=x+dx[i];
        tempy=y+dy[i];
        if(safe(tempx,tempy)==1)
        {
            map[tempx][tempy]=0;
           // pirnt();
            dfs(tempx,tempy);
        }
    }
}
int main(int argc, const char * argv[]) {
    //freopen("/Users/zhangjiatao/Desktop/input.txt","r",stdin);
    while(scanf("%d%d",&m,&n)==2)
    {
        if(m==0&&n==0) return 0;
        for(int i=1;i<=m;i++)
        {
            for(int j=1;j<=n;j++)
            {
                char temp;
                cin>>temp;
                if(temp=='@') map[i][j]=1;
                else map[i][j]=0;
            }
        }
        counter=0;
        //pirnt();
        for(int i=1;i<=m;i++)
        {
            for(int j=1;j<=n;j++)
            {
                if (map[i][j]==1) map[i][j]=0,dfs(i,j),counter++;
            }
        }
        cout<<counter<<endl;
    }
    return 0;
}
总结
dfs不一定就是要回溯法,本题中就利用dfs进行了递归式的向周围8个方向的拓展遍历。

debug总结
1.对开始点没有进行处理,在dfs中要注意对开始点进行小心的处理
2.countr的位置不对,还是写程序的时候不够专心,写错了。

你可能感兴趣的:(HDOJ 1241Oil Deposits(BFS))