杭电oj~~1021

尝试了很多办法,用打表,数组遍历都不行,要不超时要不数据溢出,最后想,利用求余运算,终于AC了。

题目描述:

Problem Description
There are another kind of Fibonacci numbers: F(0) = 7, F(1) = 11, F(n) = F(n-1) + F(n-2) (n>=2).
 

Input
Input consists of a sequence of lines, each containing an integer n. (n < 1,000,000).
 

Output
Print the word "yes" if 3 divide evenly into F(n).

Print the word "no" if not.
 

Sample Input
   
   
   
   
0 1 2 3 4 5
 

Sample Output
   
   
   
   
no no yes no no no

AC代码:

import java.util.Scanner;

public class Main {
public static void main(String[] args) {
		Scanner in = new Scanner(System.in);
		
		while(in.hasNext())
		{
			int a,b,c,t=0,i;
			a = 7;b = 11;
			c = in.nextInt();
			if(c==0||c==1)
			{
				System.out.println("no");
			}
			else
			{
			  for(i=2;i<=c;i++)
			 {
				t = (a+b)%3;
				a = b%3;
				b = t%3;
			 }
			  if(t%3==0)
			 {
				System.out.println("yes");
			 }
			 else
			 {
				System.out.println("no");
		 	 }
		 }
	   } 
	}
}


你可能感兴趣的:(杭电oj~~1021)