2015 网络赛 Alisha’s Party

Alisha’s Party

Time Limit: 3000/2000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 2676    Accepted Submission(s): 727


Problem Description
Princess Alisha invites her friends to come to her birthday party. Each of her friends will bring a gift of some value  v , and all of them will come at a different time. Because the lobby is not large enough, Alisha can only let a few people in at a time. She decides to let the person whose gift has the highest value enter first.

Each time when Alisha opens the door, she can decide to let  p  people enter her castle. If there are less than  p  people in the lobby, then all of them would enter. And after all of her friends has arrived, Alisha will open the door again and this time every friend who has not entered yet would enter.

If there are two friends who bring gifts of the same value, then the one who comes first should enter first. Given a query  n  Please tell Alisha who the  nth  person to enter her castle is.
 

Input
The first line of the input gives the number of test cases,  T  , where  1T15 .

In each test case, the first line contains three numbers  k,m  and  q  separated by blanks.  k  is the number of her friends invited where  1k150,000 . The door would open m times before all Alisha’s friends arrive where  0mk . Alisha will have  q  queries where  1q100 .

The  ith  of the following  k  lines gives a string  Bi , which consists of no more than  200  English characters, and an integer  vi 1vi108 , separated by a blank.  Bi  is the name of the  ith  person coming to Alisha’s party and Bi brings a gift of value  vi .

Each of the following  m  lines contains two integers  t(1tk)  and  p(0pk)  separated by a blank. The door will open right after the  tth  person arrives, and Alisha will let  p  friends enter her castle.

The last line of each test case will contain  q  numbers  n1,...,nq  separated by a space, which means Alisha wants to know who are the  n1th,...,nqth  friends to enter her castle.

Note: there will be at most two test cases containing  n>10000 .
 

Output
For each test case, output the corresponding name of Alisha’s query, separated by a space.
 

Sample Input
   
   
   
   
1 5 2 3 Sorey 3 Rose 3 Maltran 3 Lailah 5 Mikleo 6 1 1 4 2 1 2 3
 

Sample Output
   
   
   
   
Sorey Lailah Rose
 

Source
2015 ACM/ICPC Asia Regional Changchun Online
 

Recommend
hujie   |   We have carefully selected several similar problems for you:   5449  5448  5447  5446  5445 

#include <map>
#include <queue>
#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>
using namespace std;
#define N 150000 + 10
#define M 205
int k, m, q;
struct person
{
    char s[M];
    int v;
    int id;
}P[N];
struct cmp
{
    bool operator() (const person &a, const person &b) const{
    return a.v == b.v ? a.id > b.id : a.v < b.v;
    }
};
vector<int> mm;
pair<int, int> t[N];

int main()
{
    int T;
    scanf("%d", &T);
    while(T--)
    {
        priority_queue<person, vector<person>, cmp> Q;
        mm.clear();
        scanf("%d%d%d", &k, &m, &q);
        for(int i = 1; i <= k; i++)
        {
            scanf("%s", P[i].s);
            scanf("%d", &P[i].v);
            P[i].id = i;
        }
        int cnt = 1;
        for(int i = 0; i < m; i++)  scanf("%d%d", &t[i].first, &t[i].second);
        sort(t, t + m);
        for(int i = 0; i < m; i++)
        {
            for(; cnt <= t[i].first; cnt++)
                Q.push(P[cnt]);
            for(int j = 1; j <= t[i].second && !Q.empty(); j++)
            {
                person tmp = Q.top();
                mm.push_back(tmp.id);
                Q.pop();
            }
        }
        if(mm.size() < k)
        {
            for(int i = cnt; i <= k; i++)
            Q.push(P[i]);
            for(int i = mm.size() + 1; i <= k; i++)
            {
                person tmp = Q.top();
                mm.push_back(tmp.id);
                Q.pop();
            }
        }


        for(int i = 1; i <= q; i++)
        {
            int tmp;
            scanf("%d", &tmp);

            (i == q) ? printf("%s\n", P[mm[tmp - 1]].s) : printf("%s ", P[mm[tmp - 1]].s);
        }
    }
    return 0;
}
/*
100
1
3
3 2 3
A 2
B 1
C 2
1 0
3 2
1 2 3
1 1 1
a 1
1 0
1

1
5 2 5
Sorey 3
Rose 3
Maltran  3
Lailah 5
Mikleo  6
4 2
1 1
1 2 3 4 5
*/


你可能感兴趣的:(ACM,HDU)