HDU 2545 树上战争(并查集)

树上战争

Time Limit: 10000/4000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 493    Accepted Submission(s): 261


Problem Description
给一棵树,如果树上的某个节点被某个人占据,则它的所有儿子都被占据,lxh和pfz初始时分别站在两个节点上,谁当前所在的点被另一个人占据,他就输了比赛,问谁能获胜
 

Input
输入包含多组数据
每组第一行包含两个数N,M(N,M<=100000),N表示树的节点数,M表示询问数,N=M=0表示输入结束。节点的编号为1到N。
接下来N-1行,每行2个整数A,B(1<=A,B<=N),表示编号为A的节点是编号为B的节点的父亲
接下来M行,每行有2个数,表示lxh和pfz的初始位置的编号X,Y(1<=X,Y<=N,X!=Y),lxh总是先移动

 

Output
对于每次询问,输出一行,输出获胜者的名字
 

Sample Input
   
   
   
   
2 1 1 2 1 2 5 2 1 2 1 3 3 4 3 5 4 2 4 5 0 0
 

Sample Output
   
   
   
   
lxh pfz lxh 提示: 本题输入、输出都很多,请使用scanf和printf代替cin、cout。
 

Source
UESTC 6th Programming Contest Online
 

Recommend
lcy   |   We have carefully selected several similar problems for you:   2546  2544  2538  2540  2539 
 

#include<stdio.h>
int father[100005];
int find(int n)
{
    int num=0;
    while(n!=father[n])
    {
        n=father[n];
        num++;
    }
    return num;
}
int main()
{
    int n,m;
    while(~scanf("%d%d",&n,&m)&&(n||m))
    {
        int x,y;
        int a,b;
        for(int i=1; i<=n; i++)
            father[i]=i;
        for(int i=1; i<n; i++)
        {
            scanf("%d%d",&x,&y);
            father[y]=x;
        }
        while(m--)
        {

            scanf("%d%d",&a,&b);
            int px=find(a);
            int py=find(b);
            if(px<=py)
                printf("lxh\n");
            else
                printf("pfz\n");
        }
    }
    return 0;
}

你可能感兴趣的:(HDU)