hdu 1009 FatMouse' Trade

Problem Description
FatMouse prepared M pounds of cat food, ready to trade with the cats guarding the warehouse containing his favorite food, JavaBean.
The warehouse has N rooms. The i-th room contains J[i] pounds of JavaBeans and requires F[i] pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get J[i]* a% pounds of JavaBeans if he pays F[i]* a% pounds of cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain.



Input
The input consists of multiple test cases. Each test case begins with a line containing two non-negative integers M and N. Then N lines follow, each contains two non-negative integers J[i] and F[i] respectively. The last test case is followed by two -1's. All integers are not greater than 1000.



Output
For each test case, print in a single line a real number accurate up to 3 decimal places, which is the maximum amount of JavaBeans that FatMouse can obtain.



Sample Input
5 3
7 2
4 3
5 2
20 3
25 18
24 15
15 10
-1 -1


Sample Output
13.333

31.500

本来像这种水题不打算放博客上的,但是,但是,我交了三遍,只当买个教训,开始用float怎么也交不上去,后来改了一下用double就AC 了,怪郁闷

#include<stdio.h>
#include<iostream>
#include<string.h>
#include<algorithm>
using namespace std;
typedef struct node{
    int x,y;
    double average;
}node;
node a[10000];
bool cmp(node m1,node m2)
{
    return m1.average>m2.average;
}
int main()
{
    int m,n;
    while (scanf("%d%d",&m,&n),m!=-1||n!=-1)
    {
        int i;
        double ant=0.0;
        for (i=0;i<n;i++)
            {
                scanf("%d%d",&a[i].x,&a[i].y);
                a[i].average=a[i].x*1.0/a[i].y;
            }
        sort(a,a+n,cmp);
        for (i=0;i<n;i++)
        {
          if (a[i].y<=m)
          {
               ant+=a[i].x;
              m-=a[i].y;
          }
          else
          {
              ant+=m*a[i].average;
                break;
          }
        }
            printf("%.3lf\n",ant);
    }
    return 0;
}

你可能感兴趣的:(hdu 1009 FatMouse' Trade)