A - Anagrams by Stack hdu 1515

问题描述

How can anagrams result from sequences of stack operations? There are two sequences of stack operators which can convert TROT to TORT:

[
i i i i o o o o
i o i i o o i o
]

where i stands for Push and o stands for Pop. Your program should, given pairs of words produce sequences of stack operations which convert the first word to the second.


输入

The input will consist of several lines of input. The first line of each pair of input lines is to be considered as a source word (which does not include the end-of-line character). The second line (again, not including the end-of-line character) of each pair is a target word. The end of input is marked by end of file.


输出

For each input pair, your program should produce a sorted list of valid sequences ofi and o which produce the target word from the source word. Each list should be delimited by

[
]
and the sequences should be printed in "dictionary order". Within each sequence, each i and o is followed by a single space and each sequence is terminated by a new line.

Process

A stack is a data storage and retrieval structure permitting two operations:

Push - to insert an item and
Pop - to retrieve the most recently pushed item

We will use the symbol i (in) for push and o (out) for pop operations for an initially empty stack of characters. Given an input word, some sequences of push and pop operations are valid in that every character of the word is both pushed and popped, and furthermore, no attempt is ever made to pop the empty stack. For example, if the word FOO is input, then the sequence:

i i o i o o is valid, but
i i o is not (it's too short), neither is
i i o o o i (there's an illegal pop of an empty stack)

Valid sequences yield rearrangements of the letters in an input word. For example, the input word FOO and the sequencei i o i o o produce the anagram OOF. So also would the sequence i i i o o o. You are to write a program to input pairs of words and output all the valid sequences ofi and o which will produce the second member of each pair from the first.


样例输入

madam
adamm
bahama
bahama
long
short
eric
rice

样例输出

[
i i i i o o o i o o 
i i i i o o o o i o 
i i o i o i o i o o 
i i o i o i o o i o 
]
[
i o i i i o o i i o o o 
i o i i i o o o i o i o 
i o i o i o i i i o o o 
i o i o i o i o i o i o 
]
[
]
[
i i o i o i o o 
]



这道题要求我们模拟栈的入栈出栈操作,可以用dfs来完成
假设从a数字串变到b数字串;
由于题目要求最后输出是按字典序输出,所以可以先将a的元素递归全部入栈,然后再回溯判断栈顶元素是否与相等
若相等,则出栈,并且递归下一层;
若不相等,则返回;


代码如下 仅供参考:


#include <iostream>
#include <stdio.h>
#include <algorithm>
#include <stack>
#include <string.h>
#include <vector>
#include <queue>
using namespace std;

char aa[1000];int lena,lenb;
char stackk[1000];

string a,b;//a,b两个字符串

void dfs(int cur1,int top,int cur2,int step)//cur1表示a的下表,cur2表示b的下标
{
    int t=0;
    if(cur2==lenb)//成功的情况
    {
        for(int i=0;i<step;i++)
            cout<<aa[i]<<" ";
        cout<<endl;
        return ;
    }
       
    if(cur1<lena)
       {//先入栈
           t=top+1;
           aa[step]='i';
           char temp=stackk[t];//先保存下来
           stackk[t]=a[cur1];
           dfs(cur1+1,t,cur2,step+1);
           stackk[t]=temp;//恢复栈顶
       }


       if(top!=-1&&stackk[top]==b[cur2])
       {//栈顶元素与目标元素相等;
           aa[step]='o';
           t=top-1;//出栈;
           dfs(cur1,t,cur2+1,step+1);
       }
}

int main()
{

    while(cin>>a>>b)
    {

        lena=a.length();
        lenb=b.length();
        memset(aa,0,sizeof(aa));
        memset(stackk,0,sizeof(stackk));

        cout<<"["<<endl;
        if(lena>=lenb)
            dfs(0,-1,0,0);

        cout<<"]"<<endl;
    }
}

你可能感兴趣的:(A - Anagrams by Stack hdu 1515)