UVA 624 CD(01背包+dp打印路径)

A - CD
Time Limit:3000MS     Memory Limit:0KB     64bit IO Format:%lld & %llu
Submit  Status  Practice  UVA 624
Appoint description:  acmparand  (2013-07-30)System Crawler  (2015-11-10)

Description

You have a long drive by car ahead. You have a tape recorder, but unfortunately your best music is on CDs. You need to have it on tapes so the problem to solve is: you have a tape N minutes long. How to choose tracks from CD to get most out of tape space and have as short unused space as possible.


Assumptions:

  • number of tracks on the CD. does not exceed 20
  • no track is longer than N minutes
  • tracks do not repeat
  • length of each track is expressed as an integer number
  • N is also integer

Program should find the set of tracks which fills the tape best and print it in the same sequence as the tracks are stored on the CD

Input 

Any number of lines. Each one contains value  N, (after space) number of tracks and durations of the tracks. For example from first line in sample data:  N=5, number of tracks=3, first track lasts for 1 minute, second one 3 minutes, next one 4 minutes

Output 

Set of tracks (and durations) which are the correct solutions and string ``  sum:" and sum of duration times.

Sample Input 

5 3 1 3 4
10 4 9 8 4 2
20 4 10 5 7 4
90 8 10 23 1 2 3 4 5 7
45 8 4 10 44 43 12 9 8 2

Sample Output 

1 4 sum:5
8 2 sum:10
10 5 4 sum:19
10 23 1 2 3 4 5 7 sum:55
4 10 12 9 8 2 sum:45


Miguel A. Revilla

2000-01-10


//题意:CD上有n首歌,每首歌曲时长已知,歌曲没有重复的,想要将CD上的歌拷到磁带上,磁带的容量已知,求解拷贝哪几首歌会使磁带的空间使用率最大。(输出任意一种最优解的方案即可)

//这题也是01背包问题,最优解很好求,但难点在于最优解的方案也要求出。因此在用一个二维数组p[i][v]标记容量为v时第i首歌是否选取。
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
const int maxm=1e3+10;
int dp[maxm];
int p[25][10005];
int v[maxm];
int main()
{
    int w;
    while(scanf("%d",&w)!=EOF)
    {
        memset(dp,0,sizeof(dp));
        memset(p,0,sizeof(p));
        int n;
        scanf("%d",&n);
        for(int i=0;i<n;i++)
        {
            scanf("%d",&v[i]);
        }
        for(int i=n-1;i>=0;i--)
        {
            for(int j=w;j>=v[i];j--)
            {
                if(dp[j]<dp[j-v[i]]+v[i])
                {
                    dp[j]=dp[j-v[i]]+v[i];
                    p[i][j]=1;
                }
            }
        }
        for(int i=0,j=w;i<n&&j>=0;i++)
        {
            if(p[i][j])
            {
                printf("%d ",v[i]);
                j-=v[i];
            }
        }
        printf("sum:%d\n",dp[w]);
    }
    return 0;
}


你可能感兴趣的:(UVA 624 CD(01背包+dp打印路径))