POJ 3732 —— kruskal

Conscription
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 6529   Accepted: 2228

Description

Windy has a country, and he wants to build an army to protect his country. He has picked up N girls and M boys and wants to collect them to be his soldiers. To collect a soldier without any privilege, he must pay 10000 RMB. There are some relationships between girls and boys and Windy can use these relationships to reduce his cost. If girlx and boy y have a relationship d and one of them has been collected, Windy can collect the other one with 10000-d RMB. Now given all the relationships between girls and boys, your assignment is to find the least amount of money Windy has to pay. Notice that only one relationship can be used when collecting one soldier.

Input

The first line of input is the number of test case.
The first line of each test case contains three integers, NM and R.
Then R lines followed, each contains three integers xiyi and di.
There is a blank line before each test case.

1 ≤ NM ≤ 10000
0 ≤ R ≤ 50,000
0 ≤ xi < N
0 ≤ yi < M
0 < di < 10000

Output

For each test case output the answer in a single line.

Sample Input

2

5 5 8
4 3 6831
1 3 4583
0 0 6592
0 1 3063
3 3 4975
1 3 2049
4 2 2104
2 2 781

5 5 10
2 4 9820
3 2 6236
3 1 8864
2 4 8326
2 0 5156
2 0 1463
4 1 2439
0 4 4373
3 4 8889
2 4 3133

Sample Output

71071
54223

Source

POJ Monthly Contest – 2009.04.05, windy7926778

变形的kruskal,转化为无向图的最大权森林。可把边权取反后用kruskal求最小生成树。

#include <cstdio>
#include <cmath>
#include <algorithm>
#include <iostream>
#include <cstring>
#include <map>
#include <string>
#include <stack>
#include <cctype>
#include <vector>
#include <queue>
#include <set>
#include <utility>
#include <cassert>
using namespace std;
///#define Online_Judge
#define outstars cout << "***********************" << endl;
#define clr(a,b) memset(a,b,sizeof(a))
#define lson l , mid  , rt << 1
#define rson mid + 1 , r , rt << 1 | 1
#define mk make_pair
#define FOR(i , x , n) for(int i = (x) ; i < (n) ; i++)
#define FORR(i , x , n) for(int i = (x) ; i <= (n) ; i++)
#define REP(i , x , n) for(int i = (x) ; i > (n) ; i--)
#define REPP(i ,x , n) for(int i = (x) ; i >= (n) ; i--)
const int MAXN = 50000 + 50;
const int MAXS = 20000 + 50;
const int sigma_size = 26;
const long long LLMAX = 0x7fffffffffffffffLL;
const long long LLMIN = 0x8000000000000000LL;
const int INF = 0x7fffffff;
const int IMIN = 0x80000000;
const int inf = 1 << 30;
#define eps 1e-8
const int MOD = (int)1e9 + 7;
typedef long long LL;
const double PI = acos(-1.0);
typedef double D;
typedef pair<int , int> pii;
#define Bug(s) cout << "s = " << s << endl;
///#pragma comment(linker, "/STACK:102400000,102400000")
int n , m , r , V , E;
int x[MAXN] , y[MAXN] , d[MAXN];
int par[MAXN] , rank[MAXN];
struct edge
{
    int u , v ,cost;
    edge(){}
    edge(int x , int y , int w)
    {
        u = x , v = y , cost = w;
    }
};
bool cmp(const edge & e1 , const edge & e2)
{
    return e1.cost < e2.cost ;
}
void init_union_find(int n)
{
    for(int i = 0 ; i < n ; i++)
    {
        par[i] = i;
        rank[i] = 0;
    }
}
int find(int x)
{
    return x == par[x] ? x : par[x] = find(par[x]);
}
void unite(int x , int y)
{
    x = find(x);
    y = find(y);
    if(x == y)return ;
    if(rank[x] < rank[y])par[x] = y;
    else
    {
        par[y] = x;
        if(rank[x] == rank[y])rank[x]++;
    }
}
bool same(int x ,int y)
{
    return find(x) == find(y);
}
edge es[MAXN];
int kruskal()
{
    sort(es , es + E , cmp);
    init_union_find(V);
    int ans = 0;
    for(int i = 0 ; i < E ;i++)
    {
        edge e = es[i];
        if(!same(e.u , e.v))
        {
            unite(e.u , e.v);
            ans += e.cost;
        }
    }
    return ans;
}
void solve()
{
    V = m + n;
    E = r;
    for(int i = 0 ; i < r ; i++)
    {
        es[i] =(edge){x[i] , y[i] + n , -d[i]};
    }
    printf("%d\n" , (n + m) * 10000 + kruskal());
}
int main()
{
    int t;
    cin >> t;
    while(t--)
    {
        scanf("%d%d%d" , &n ,&m , &r);
        for(int i = 0 ; i < r;  i++)
        {
            scanf("%d%d%d" , &x[i] , &y[i] , &d[i]);
        }
        solve();
    }
    return 0;
}


你可能感兴趣的:(ACM,kruskal)