UVA - 10391 Compound Words(hash)

Problem E: Compound Words

You are to find all the two-word compound words in a dictionary. A two-word compound word is a word in the dictionary that is the concatenation of exactly two other words in the dictionary.

Input

Standard input consists of a number of lowercase words, one per line, in alphabetical order. There will be no more than 120,000 words.

Output

Your output should contain all the compound words, one per line, in alphabetical order.

Sample Input

a
alien
born
less
lien
never
nevertheless
new
newborn
the
zebra

Sample Output

alien
newborn

题目大意:求出一个由两个单词组成的单词,并按照字典序输出。

解析:这题比较简单,直接暴力用set+string stl暴力求解,详见代码。

#include <string>
#include <set>
#include <iostream>
using namespace std;
int main() {
	string word;
	set<string> st;
	while(cin >> word) {
		st.insert(word);
	}
	set<string>::iterator it; 
	for(it = st.begin(); it != st.end(); it++) {
		for(int i = 1; i < (*it).size(); i++) {
			string front = (*it).substr(0,i);
			string rear = (*it).substr(i);
			if(st.count(front) && st.count(rear)) {
				cout << (*it) << endl;
				break;
			}
		}
	}
	return 0;
}

你可能感兴趣的:(uva,words,compound,10391)