2015年第十四周oj刷题:比较大小-类模板

Problem I: C++ 习题 比较大小-类模板

Time Limit: 1 Sec   Memory Limit: 128 MB
Submit: 948   Solved: 656
[ Submit][ Status][ Web Board]

Description

声明一个类模板,利用它分别实现两个整数、浮点数和字符的比较,求出大数和小数。说明:在类模板外定义各成员函数。

Input

输入两个整数、两个浮点数和两个字符

Output

从大到小输出两个整数、两个浮点数和两个字符

Sample Input

3 7
45.78 93.6
a A

Sample Output

7 3
93.60 45.78
a A

HINT

#include <iostream>

#include <iomanip>

using namespace std;

template<class numtype>

class Compare

{

public:

    Compare(numtype a,numtype b);

    numtype max();

    numtype min();

private:

    numtype x,y;

};
template<class numtype>
Compare<numtype>::Compare(numtype a,numtype b)
{
    x=a;
    y=b;
}
template<class numtype>
numtype Compare<numtype>::max()
{
    if(x>y)return x;
    else return y;
}
template<class numtype>
numtype Compare<numtype>::min()
{
    if(x>y)return y;
    else return x;
}
int main()

{

    int i1,i2;

    cin>>i1>>i2;

    Compare<int> cmp1(i1,i2);

    cout<<cmp1.max()<<" "<<cmp1.min()<<endl;

    float f1,f2;

    cin>>f1>>f2;

    Compare<float> cmp2(f1,f2);

    cout<<setiosflags(ios::fixed);

    cout<<setprecision(2);

    cout<<cmp2.max()<<" "<<cmp2.min()<<endl;

    char c1,c2;

    cin>>c1>>c2;

    Compare<char> cmp3(c1,c2);

    cout<<cmp3.max()<<" "<<cmp3.min()<<endl;

    return 0;

}

2015年第十四周oj刷题:比较大小-类模板_第1张图片

你可能感兴趣的:(2015年第十四周oj刷题:比较大小-类模板)