HDU3466(01背包)

Proud Merchants

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 131072/65536 K (Java/Others)
Total Submission(s): 4437 Accepted Submission(s): 1837

Problem Description
Recently, iSea went to an ancient country. For such a long time, it was the most wealthy and powerful kingdom in the world. As a result, the people in this country are still very proud even if their nation hasn’t been so wealthy any more.
The merchants were the most typical, each of them only sold exactly one item, the price was Pi, but they would refuse to make a trade with you if your money were less than Qi, and iSea evaluated every item a value Vi.
If he had M units of money, what’s the maximum value iSea could get?

Input
There are several test cases in the input.

Each test case begin with two integers N, M (1 ≤ N ≤ 500, 1 ≤ M ≤ 5000), indicating the items’ number and the initial money.
Then N lines follow, each line contains three numbers Pi, Qi and Vi (1 ≤ Pi ≤ Qi ≤ 100, 1 ≤ Vi ≤ 1000), their meaning is in the description.

The input terminates by end of file marker.

Output
For each test case, output one integer, indicating maximum value iSea could get.

Sample Input
2 10
10 15 10
5 10 5
3 10
5 10 5
3 5 6
2 7 3

Sample Output
5
11

有限制的01背包,因为有了限制所以我们需要对所有的商人做排序q-a尽量小认为是更优的,如果不排序就不能每次迭代出最优解。比如,最后一个商人实际上是在最优解中需要选取的,但是不排序时因为在后面,剩下的钱不够了,选到他的时候已经不能再和他进行交易了,排序能解决这个问题。其他就和普通的01背包差不多了。

#include "cstring"
#include "cstdio"
#include "iostream"
#include "algorithm"
using namespace std;
typedef struct node
{
    int p;
    int q;
    int v;

}node;
node list[502];
bool cmp(node a,node b)
{
    return a.q-a.p<b.q-b.p;
}
int dp[5002];
int main()
{
    int n,m;
    while(~scanf("%d%d",&n,&m))
    {
        for(int i=1;i<=n;i++)
            scanf("%d%d%d",&list[i].p,&list[i].q,&list[i].v);
        memset(dp,0,sizeof(dp));
        sort(list+1,list+n+1,cmp);
        for(int i=1;i<=n;i++)
        {
            for(int j=m;j>=list[i].p;j--)
            {
                if(j>=list[i].q)
                    dp[j]=max(dp[j],dp[j-list[i].p]+list[i].v);
            }
        }
        printf("%d\n",dp[m]);
    }
}

你可能感兴趣的:(HDU3466(01背包))